I have Windows 7 Ultimate 64 bit installed on a fast PC (500GB SSD, i7-6700 and Z170 chipset). It says 'Service Pack 1', yet I always install the latest Windows updates; I would have thought it was Service Pack 2.
I also have PuTTY v0.67 (with Pageant and PuTTYgen) installed also under x86 (32 bit).
When I tried to install v5.11.3 (12.1.18) and v5.13) (23.2.18) by double-clicking, I got an error message as follows:
"The version of this file is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the publisher."
I got this message both before and after uninstalling v5.9.6.
When I try and reinstall v5.9.6, I don't get the same blocking message. I've now reinstalled it and it's working.
I just note on the installation that, because I already had the PuTTY family of programs loaded, I didn't install them again when I installed WinSCP v5.9.6 just now. I hope that seems sensible. I'm using them actively, and I don't want to lose settings unless I have to.
Can you advise me on how to upgrade?
PS: I also have Git Bash installed as a 64 bit program, with mingw64.