Wrong date/time after uploading to mysecureshell

Advertisement

HansV
Joined:
Posts:
1
Location:
Netherlands

Wrong date/time after uploading to mysecureshell

When uploading a file to a Ubuntu server with mysecureshell running as shell the file date/time stamps are wrong after uploading. Instead of using the old filedate/filetime, the date/time of upload is used. This seems to be a regression, as it was working properly in version 5.9.2

As of version 5.9.3 all WinSCP versions show this problem.

I attached 2 log files (both for 5.9.2 and for 5.9.3). As can be seen in line 144 of the 5.9.3 file timestamp 2017-06-29T12:02:41.000Z (see line 130) has been changed to 2018-03-06T13:20:16.000Z

When transferring files with version 5.9.2 the timestamp is correct after uploading.
The ubuntu server uses mysecureshell version 2.0 feb 17 2016 (installed from the default Ubuntu repository)
Description: version 5.93: wrong date/time after uploading
Description: version 5.92 works correct

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,658
Location:
Prague, Czechia

Re: Wrong date/time after uploading to mysecureshell

A change in 5.9.3 is that it is no longer setting "last access" time of uploaded files.
But the timestamp that WinSCP shows in the log is "last modification" time.
What hints that MySecureShell may have a bug that it uses "last access" time to set "last modification" time. Or that it cannot handle an absence of "last access" time in the request.

Reply with quote

Advertisement

You can post new topics in this forum