Drag and Drop FROM any server is bugged

Advertisement

Mikhail Zhabin
Guest

Drag and Drop FROM any server is bugged

Dragging and dropping files from user PC to host folders works fine, but when I try to drag files FROM the server mouse doesn't change cursor icon and doesn't drag the file for approximately 3 seconds. This happens to any file. This also happens if I want to move file to folder on the host as well. Selecting multiple files works correctly, it seems only dragging from host is affected. Tried multiple servers.

Using WinSCP 5.13.2 with “Commander” interface on Windows 10. It happens for any stored session in subfolder, regardless of protocol or server. So I’m not posting session log file as it seems irrelevant.
  • capture.gif (110.59 KB, Private file)
Description: A GIF caption of the situation for visualisation (24 fps).

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,811
Location:
Prague, Czechia

Re: Drag and Drop FROM any server is bugged

Thanks for your report.

I assume your Windows 10 got already updated to version 1803, right?

How many local drives (letters) do you have? What kind of drives do you have (any network drives, DVD/CD, anything special)?

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Reply with quote

Mikhail Zhabin
Guest

Re: Drag and Drop FROM any server is bugged

martin wrote:

Thanks for your report.

I assume your Windows 10 got already updated to version 1803, right?

How many local drives (letters) do you have? What kind of drives do you have (any network drives, DVD/CD, anything special)?

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

That is correct, my version of win10 is 1803. I have two local drives (SSD and HDD). No external drives at all (not even DVD drives or flash dongles). I do have a raspberry pi server on the same local network but I don't know how this would affect this issue.

You can send me a debug version to this address: theemoyo at gmail dot com. I don't mind sharing my email it's not really, important, but if you require me to email you first - I'll happily register and send you an email first.

Thanks for your response, hope I could help WinSCP with my input. Cheers.

Reply with quote

tmtben
Joined:
Posts:
5

Hi,

I also have issue using Explorer interface and drag'n drop.

WinSCP create a temporary /scp* folder and next show modal window:
"WinSCP does not manage to identify where the file has been transfered"

Thanks,
Ben

Reply with quote

tmtben
Joined:
Posts:
5

Hi,
Using Commander Interface, I notice WinSCP is trying to use an old network drive.
Maybe Explorer Interface is trying to use this same old drive...
Hope it helps.
Ben

Reply with quote

Advertisement

tmtben
Joined:
Posts:
5

More info:

With Explorer interface, I can drag'n drop files using "temp dir" option.
My issue is about drag'n drop using "shell extensions" option.

Ben

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,811
Location:
Prague, Czechia

Re: Drag and Drop FROM any server is bugged

Mikhail Zhabin wrote:

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.
Thanks. Sent.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,811
Location:
Prague, Czechia

tmtben wrote:

I also have issue using Explorer interface and drag'n drop.

WinSCP create a temporary /scp* folder and next show modal window:
"WinSCP does not manage to identify where the file has been transfered"
Seems like a separate problem. Can you start a new thread and tell us your version of Windows and WinSCP?

Reply with quote

tmtben
Joined:
Posts:
5

martin wrote:

Seems like a separate problem. Can you start a new thread and tell us your version of Windows and WinSCP?
Done :-)

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,811
Location:
Prague, Czechia

Re: Drag and Drop FROM any server is bugged

Mikhail Zhabin wrote:

Dragging and dropping files from user PC to host folders works fine, but when I try to drag files FROM the server mouse doesn't change cursor icon and doesn't drag the file for approximately 3 seconds. This happens to any file. This also happens if I want to move file to folder on the host as well. Selecting multiple files works correctly, it seems only dragging from host is affected. Tried multiple servers.
This issue has been added to the tracker:
https://winscp.net/tracker/1652

Reply with quote

Advertisement

You can post new topics in this forum