WinSCP UI Extremely slow

Advertisement

stAn99
Guest

WinSCP UI Extremely slow

Hello, in last few WinSCP versions, the UI got extremely slow. i believe this happened once new protocols were implemented.

We are on latest Win10 build 1803 x64
We've got thousands of FTP+SCP accounts stored (no other protocols are used)
We are using RDP sessions on our Win10 which runs under KVM/qemu virtual machine on Ubuntu 16.04
We are on Intel i7 + 20gb RAM dedicated to Win10 VPS and the windows itself is very fast except WinSCP
We have only a standard virtual GPU (qxl) without any acceleration (no PCI forwading/virtualization is configured for GPU)

We use RDP because we do not turn off or restart the PC for a long time (sometimes even a few months) and when reconecting to RDP, WinSCP UI gets locked and all opened sessions take about 10 to 20 minutes to be available for work. This is an extremely long time compared to older WinSCP versions where we had never had this problem.

Any help is appreciated.

Best Regards, stAn

Reply with quote

Advertisement

Guest

Re: WinSCP UI Extremely slow

I have noticed a slowdown with 5.13.2 on w1064 - 1709. Only 4 saved sessions. After logging in, the ui will not respond for 15 seconds or so. This just started occurring.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,542
Location:
Prague, Czechia

Re: WinSCP UI Extremely slow

stAn99 wrote:

Hello, in last few WinSCP versions, the UI got extremely slow. i believe this happened once new protocols were implemented.
Can you please find out what version did introduce the problem?
You can download old versions of WinSCP from: https://sourceforge.net/projects/winscp/files/WinSCP/

And/or: Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,542
Location:
Prague, Czechia

Re: WinSCP UI Extremely slow

Anonymous wrote:

I have noticed a slowdown with 5.13.2 on w1064 - 1709. Only 4 saved sessions. After logging in, the ui will not respond for 15 seconds or so. This just started occurring.
Slowdown comparing to what?

Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Reply with quote

Advertisement

You can post new topics in this forum