Public key authetication is passed to PUTTY (or not working) in latest version

Advertisement

ttomika
Joined:
Posts:
4

Public key authetication is passed to PUTTY (or not working) in latest version

Hi all,

In version 5.13.3 when opening Putty from WinSCP session key seems to be not passed.
This works with previous versions.

May I missed a new setting or something?

Thanks for your help in advance.

Best Regards,
Tom

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,095
Location:
Prague, Czechia

Re: Public key authetication is passed to PUTTY (or not working) in latest version

Thanks for your report.
What versions were you using previously? Did it work in 5.13.2?

Reply with quote

ttomika
Joined:
Posts:
4

Re: Public key authetication is passed to PUTTY (or not working) in latest version

martin wrote:

Thanks for your report.
What versions were you using previously? Did it work in 5.13.2?

I can't remember so downloaded and tried 5.13.2.
That version works fine.

Best Regards,
Tom

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,095
Location:
Prague, Czechia

Re: Public key authetication is passed to PUTTY (or not working) in latest version

Please host down Ctrl+Shift when clicking on "Open in PuTTY" command in both versions.
It makes WinSCP copy PuTTY command-line to clipboard. Post commands from both versions.

Reply with quote

ttomika
Joined:
Posts:
4

Re: Public key authetication is passed to PUTTY (or not working) in latest version

martin wrote:

Please host down Ctrl+Shift when clicking on "Open in PuTTY" command in both versions.
It makes WinSCP copy PuTTY command-line to clipboard. Post commands from both versions.

Old: "C:\Program Files (x86)\PuTTY\putty.exe" - load "WinSCP temporary session"
New: "C:\Program Files (x86)\PuTTY\putty.exe" 192.168.1.10 - l user - P 1234

Best Regards,
Tom

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,095
Location:
Prague, Czechia

Re: Public key authetication is passed to PUTTY (or not working) in latest version

There's no difference between 5.13.2 and 5.13.3 that can cause this.

But this difference can be caused by you having 5.13.3 installed from Microsoft Store, while 5.13.2 installed by WinSCP installer. Isn't this the case?

Reply with quote

ttomika
Joined:
Posts:
4

Re: Public key authetication is passed to PUTTY (or not working) in latest version

martin wrote:

There's no difference between 5.13.2 and 5.13.3 that can cause this.

But this difference can be caused by you having 5.13.3 installed from Microsoft Store, while 5.13.2 installed by WinSCP installer. Isn't this the case?

Absolutely this is the case. I've choosen this way of donation as it is suggested on the website. I hoped that this way new versions will be automatically installed.

Is there a way to make this function work in MS Store version or I have to return to the standalone version?

Best Regards,
Tom

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,095
Location:
Prague, Czechia

Re: Public key authetication is passed to PUTTY (or not working) in latest version

ttomika wrote:

Is there a way to make this function work in MS Store version or I have to return to the standalone version?
The next version will pass private key to PuTTY even when installed from Store:
https://winscp.net/tracker/1654

Reply with quote

Advertisement

You can post new topics in this forum