How do I skip the abort timer?

Advertisement

Viking
Guest

How do I skip the abort timer?

I use a script to run firmware upgrades on Ubiquity radios and then another script to apply configurations. After I upload the firmware and apply it, the radio reboots, and I get a disconnect message:

Host is not communicating for more than 15 seconds.
Still waiting...
Note: If the problem repeats, try turning off 'Optimize connection buffer size'.
Warning: Aborting this operation will close connection!
(A)bort (60 s): Abort

Is there any way I can disable the 60 second timer? The reboot doesn't take 60 seconds, and I would like to start the next script as soon as the radio has rebooted. This does make a difference, when you have 100 radios to flash.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,303
Location:
Prague, Czechia

Re: How do I skip the abort timer?

Use command-line parameter /rawconfig Interface\SessionReopenAutoStall=0

Reply with quote

Guest

Re: How do I skip the abort timer?

martin wrote:

Use command-line parameter /rawconfig Interface\SessionReopenAutoStall=0
How do I disable the timeout using a powershell .NET assembly?
I am currently using Timeout = New-TimeSpan -Minute 1 -Seconds 40 for 100 seconds. But I want it to NEVER time out.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,303
Location:
Prague, Czechia

Re: How do I skip the abort timer?

So is your question about Timeout or SessionReopenAutoStall (abort timer)?

Reply with quote

Guest

My apologies, the connection is poor for the FTP transfer; and often fails.
When I download manually; I get the abort message with the 60 second timer often.

I recently moved my Timeout from 100 seconds to 10minutes and the job hasn't failed; but honestly I'm not sure if that's just random luck or if I really should be using SessionReopenAutoStall to address maintaining my connection.

How do I use SessionReopenAutoStall=0 in the session options for my powershell?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,303
Location:
Prague, Czechia

Sorry, but I'm lost. Your original question was about you getting a timeout message because you rebooted a device. Now you ask about a poor connection. Let's focus on one problem at a time. Did my answer with /rawconfig Interface\SessionReopenAutoStall=0 help you resolving your problem with the reboot?

Reply with quote

Guest

My apologies... I am not the original poster. My question was a followup on the original question to avoid creating another thread; but I see how this has caused confusion on your end.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,303
Location:
Prague, Czechia

OK. There's no way to set an infinite timeout. Just use a very long time.

Reply with quote

Advertisement

You can post new topics in this forum