Remote panel does not automatically refresh directory after a recursive chmod operation

Advertisement

aldemarcalazans
Guest

Remote panel does not automatically refresh directory after a recursive chmod operation

In my development server, every time I extract a .tgz or .zip file, I need to change the permissions to 0664 (file) and 0775 (folder).
To simplify this task, I created a custom command line as follows:

Set permissions to 0664 and 0775
chmod --recursive u=rwX,g=rwX,o=rX !&

I noticed that it works perfectly, except by the fact that the new permissions are not imemdiately seen, unless you manually refresh the directory.
Note: the checkbox at Panel|Remote|Remote panel|Automatically refresh diferctory after operation is checked!

Operating system: Windows 7
WinSCP version: 5.13.4
protocol: SFTP
GUI: commander interface

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,561
Location:
Prague, Czechia

Re: Remote panel does not automatically refresh directory after a recursive chmod operation

For me the current directory is refreshed - but cache for subfolders is not.
Is this what you mean?
Or do you have the problem even with the current directory?

Reply with quote

aldemarcalazans
Guest

Re: Remote panel does not automatically refresh directory after a recursive chmod operation

Yes, this is what happens: the problem is with the subfolders and files inside them.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,561
Location:
Prague, Czechia

Re: Remote panel does not automatically refresh directory after a recursive chmod operation

OK. WinSCP cannot know what the command does. So for some, like you, the problem is that the subfolder cache is not reset. While on the other hand, for others, resetting the cache might be a problem, if they usually execute custom commands that do not modify nested files.

Reply with quote

aldemarcalazans
Guest

Perhaps adding to the "Edit Custom Command" dialog box a check box with the option "Reset subfolders cache" would be a solution for this problem and similars one's - see attached.

Description: "Edit Custom Command" dialog box - suggestion for modification

edit-custom-command.png

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
29,561
Location:
Prague, Czechia

aldemarcalazans wrote:

Perhaps adding to the "Edit Custom Command" dialog box a check box with the option "Reset subfolders cache" would be a solution for this problem and similars one's - see attached.
Thanks for your suggestion.
Will see if more people ask for this.

Reply with quote

Advertisement

You can post new topics in this forum