Starting PuTTY from WinSCP in the new version stopped working

Advertisement

f2065
Joined:
Posts:
2

Starting PuTTY from WinSCP in the new version stopped working

I use SSH / SFTP with ppk keys, when I connect to the server I enter Passphrase into WinSCP. Connection normally passes, files are transferred.
Then, I launch PuTTY from WinSCP - and when starting it requires manually entering passphrase…
Although WinSCP settings specified to keep passphrase.
In the old version of WinSCP 5.13.4 - the launch of PuTTY works fine, passphrase is automatically transferred to PuTTY.
In the new versions, 5.13.5, 5.14.1.beta, you have to manually type the keys, which is very inconvenient.

Reply with quote

Advertisement

daisy.chain
Joined:
Posts:
1
Location:
Deutschland

putty ask for passphrase again

Hello, after update to 5.13.5 putty (called from winscp) ask for the passphrase of the key (already entered during new connection) again.
This is not a real bug, but ... :-)

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

Re: putty ask for passphrase again

Thanks for your reports.

This bug has been added to the tracker:
https://winscp.net/tracker/1708

I'm sending you an email with a development version of WinSCP to the address you have used to register on this forum.

Reply with quote

Shark
Joined:
Posts:
1

putty ask for passphrase again

Hi,

i have installed WinSCP v5.13.6 today. But the Bug is still alive. When i start Putty (called from Winscp) i must enter the passphrase of the key again, even though i have entered it at the winscp login.

Putty is V0.70 and i have updated Wnscp 5.13.5 -> 5.13.6 and 2nd a complete fresh install of 5.13.6
I have accept "rember session password and pass it to PUTTY (SSH)"

Sorry for by bad englisch

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
29,791
Location:
Prague, Czechia

Re: putty ask for passphrase again

Shark wrote:

i have installed WinSCP v5.13.6 today. But the Bug is still alive. When i start Putty (called from Winscp) i must enter the passphrase of the key again, even though i have entered it at the winscp login.

Putty is V0.70 and i have updated Wnscp 5.13.5 -> 5.13.6 and 2nd a complete fresh install of 5.13.6
I have accept "rember session password and pass it to PUTTY (SSH)"
Thanks for your report. Indeed. I have propagated the fix incorrectly to 5.13 branch. I'll fix it in the next release.

Reply with quote

Advertisement

You can post new topics in this forum