Topic "scripting"

Author Message
Gawron1

Guest


I am trying to write a simple scrip. I get an EAccessviolation on the open command. I have tried it thru the GUI and everything works great. But when I try the script I get the error. Here is the command I try

open abcd:password@192.123.1.1

Thanks for any help.
Advertisements
Gawron1

Guest


If i type open and press <RETURN> I get the host prompt and username/password prompts. Everything works great. But when I type open otherinformtion I get teh Eaccessviolation.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
There seems to be bug in 3.8 beta. Thanks for letting me know. Please downgrade to last stable version 3.7.6.
_________________
Martin Prikryl
Narcos
[View user's profile]

Joined: 2005-12-23
Posts: 1
Location: Glens Falls, New York, U.S.A.
i am using the latest stable version, and only on this one machine does it have issues
it's windows 2000 server enterprise

C:\>winscp3 /script="M:\Program Files\TechQuest\Backup\winscp.txt"
batch on
confirm off
EAccessViolation
No session.
transfer binary
No session.
No session.

script file contains

# Automatically answer all prompts negatively not to stall the script on errors
option batch on
# Disable overwrite confirmations that conflict with the previous
option confirm off
# Connect using a password
open scp://<user removed>:<password removed>@techquest.cc
# Change remote directory
cd /home/jgrafals/Backups/Avex
# Force binary mode transfer
option transfer binary
# Upload the backup taz
put "M:\Program Files\TechQuest\Backup\avex.taz"
# Disconnect
close
# Exit WinSCP
exit


i had this script working correctly on win xp, win2kws
this is the only win2k server i have tried it on
i am using the latest stable version (3.7.6)
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License