SSL3 alert write: fatal: bad record mac

Advertisement

pathi
Joined:
Posts:
7

SSL3 alert write: fatal: bad record mac

Hi Martin,

We are having these from past 1 week. As per your message I am sending log to your mail.

1.
TLS connection established. Waiting for welcome message...
Connection failed.
Using TLSv1.2, cipher TLSv1/SSLv3: ECDHE-RSA-AES256-SHA384, 2048 bit RSA, ECDHE-RSA-AES256-SHA384 TLSv1.2 Kx=ECDH Au=RSA Enc=AES(256) Mac=SHA384

Disconnected from server
Connection failed.

2.
Using TLSv1.2, cipher TLSv1/SSLv3: ECDHE-RSA-AES256-SHA384, 2048 bit RSA, ECDHE-RSA-AES256-SHA384 TLSv1.2 Kx=ECDH Au=RSA Enc=AES(256) Mac=SHA384

SSL3 alert write: fatal: bad record mac
decryption failed or bad record mac
Disconnected from server
Copying files to remote side failed.
(A)bort, (R)econnect (0 s): Reconnect

3.
Lost connection.
Using TLSv1.2, cipher TLSv1/SSLv3: ECDHE-RSA-AES256-SHA384, 2048 bit RSA, ECDHE-RSA-AES256-SHA384 TLSv1.2 Kx=ECDH Au=RSA Enc=AES(256) Mac=SHA384

Disconnected from server
Copying files to remote side failed.
(A)bort, (R)econnect (0 s): Reconnect
Connecting to <IP_of_server> ... not to be published: Connecting to 52.21.231.180 ...
TLS connection established. Waiting for welcome message...

Thank you,
pathi

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
30,020
Location:
Prague, Czechia

Re: SSL3 alert write: fatal: bad record mac

I haven't received any logs from you. Please post them here.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
30,020
Location:
Prague, Czechia

Re: SSL3 alert write: fatal: bad record mac

Does the problem happens for every upload? Can you upload the files using any other FTP client?

Reply with quote

pathi
Joined:
Posts:
7

Hi Martin,

Today I will try with another client and let you know.
No, not for all the files but 15%.
Even with WinSCP GUI and get also.

Thank you,
pathi

Reply with quote

Advertisement

pathi
Joined:
Posts:
7

Hi Martin,

We got additional errors with the previously associated error,

2.SSL3 alert write: fatal: bad record mac
decryption failed or bad record mac

a. Server does not send proper UTF-8, falling back to local charset

b. TLS connect: error in SSLv3 read finished A
Can't establish TLS connection

Thank you
pathi

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
30,020
Location:
Prague, Czechia

pathi wrote:

Tried with other FTP client. Able to upload and download without any issues.
Please post its verbose log file (showing upload of enough files to reproduce the problem with WinSCP).

Reply with quote

Advertisement

You can post new topics in this forum