From network drive (shared with onedrive) to SFTP: System Error. Code: 267.

Advertisement

hungeri
Joined:
Posts:
3
Location:
Budapest / Hungary

From network drive (shared with onedrive) to SFTP: System Error. Code: 267.

Hi there,
I have a network mapped (Windows) drive (Z:\), on which I have a shared onedrive directory. This means I copy anything to this network drive's directory, it will be synced to a onedrive account.
Before the sync happens (or the onedrive service on host machine is down), I easily can copy files and dirs from this drive to an SFTP, but after the onedrive sync occured, I get this "System Error. Code: 267.". What exactly happens is that WinSCP creates every time a new directory (even when copying files!) on the SFTP side and after that comes this error message. I don't know the technique onedrive uses, but after sync all my files and dirs seems to be a symlink, but any other apps are working fine: I can copy files with the Windows Explorer, or with Total Commander and the more strange is that WinSCP handles them as a file when open or run them, the error occurs only when trying to copy or move...

Any ideas, what could be wrong?

Thx in advance!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
31,935
Location:
Prague, Czechia

Re: From network drive (shared with onedrive) to SFTP: System Error. Code: 267.

What version of WinSCP are you using? Can you try the latest beta version?
What you describe sounds like this issue:
https://winscp.net/tracker/1355

If that does not help, please post a full session log file.

Reply with quote

hungeri
Joined:
Posts:
3
Location:
Budapest / Hungary

What version of WinSCP are you using?
5.13.6 (build 9061)
Can you try the latest beta version?
Yes, 5.14.2 is installed and tried out. Unfortunately the result is the same:
Error retrieving file list for "Z:\OneDrive\Dokumentumok\(...)20902.pdf\*.*".
System Error.  Code: 267.
Please look at the end of the "pathname" (which should be a filename instead as you can see the pdf extension)...
please post a full session log file
Thanks for the patience, I did it. However it logged the version number as 5.13.6, however logging occured after installing the beta version. I restored the old ini file, maybe that caused this.

Last edited by hungeri on 2018-12-27 23:25; edited 1 time in total

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
31,935
Location:
Prague, Czechia

hungeri wrote:

Thanks for the patience, I did it. However it logged the version number as 5.13.6, however logging occured after installing the beta version. I restored the old ini file, maybe that caused this.
Then you are not running 5.14.2. Please try to install it again.

Reply with quote

hungeri
Joined:
Posts:
3
Location:
Budapest / Hungary

martin wrote:

Then you are not running 5.14.2. Please try to install it again.
I've found the trick, why it was not the beta. Now it is, result is same, session log attached. Thx!
  • session.log (52.21 KB, Private file)

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
31,935
Location:
Prague, Czechia

Thanks for your report.
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

Advertisement

You can post new topics in this forum