Command line problems

Advertisement

svenhh
Joined:
Posts:
2

Command line problems

I have been adding the WinSCP installation path to the search path. Starting WinSCP from command line (or within another application)works fine when started without any argument. I starts prompting for a sesssion selection. However, when I want to create a new session using
'winscp3.exe <user>:<password>@<IP-address>/<remotepath>/', it fails with error message 'Invalid access to memory'. I suppose this should work according to doc.

Reply with quote

Advertisement

svenhh
Joined:
Posts:
2

Re: Command line problems

svenhh wrote:

I have been adding the WinSCP installation path to the search path. Starting WinSCP from command line (or within another application)works fine when started without any argument. I starts prompting for a sesssion selection. However, when I want to create a new session using
'winscp3.exe <user>:<password>@<IP-address>/<remotepath>/', it fails with error message 'Invalid access to memory'. I suppose this should work according to doc.

The port number specifier after the host name do not seem to be optional. Command line startup , creating a new session works fine if the <hostname>:22 is specified

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Command line problems

What version of WinSCP are you using?
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
27,253
Location:
Prague, Czechia

Re: Command line problems

Version 3.8.0, build 312
There is apparently a bug. It was there always, but for some reasons it emerges more often with 3.8. I'll fix it in the next version. Please try to downgrade.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum