Specify which TLS version to use for FTPS

Advertisement

joecw
Joined:
Posts:
6

Specify which TLS version to use for FTPS

I am trying to connect to my ftp server and I see this:

TLS connect: error in SSLv2/v3
Can't establish TLS connection

If the server i s using an older TLS version, how can I specify using v1.2?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
32,073
Location:
Prague, Czechia

Re: Specify which TLS version to use for FTPS

If you mean TLS 1.2, it's actually the latest version of TLS/SSL that WinSCP supports.
Are you using the latest version of WinSCP?
Can you login using any other FTPS client?

Reply with quote

joecw
Joined:
Posts:
6

Using Version 5.15.1 of WinSCP

No other FTPS clients available to check. And yes, I meant the latest version of TLS, I believe I was confusing the SSL V3 with TLS.

Reply with quote

joecw
Joined:
Posts:
6

Here is the LOG

I am still working on this. I am wondering why it is still saying implicit when I told it explicit. This is the command I am giving it:
C:\Tools\WinSCP\WinSCP.com /explicit /command "open ftps://N012:PASSWORD@agfp.intranet.agf:9921" "exit" /log="C:\Tools\WinSCP\winscp.log" /loglevel=2

Reply with quote

joecw
Joined:
Posts:
6

Okay, I got further

apparently needed to be open ftpes:\ not ftps:\
After looking at the logs, it was trying to use implicit, and using the /explicit or -explicittls comman did not make it explicit according to the log.

Having further issues but may start another topic as this seems to have gotten me further along.

Reply with quote

Advertisement

You can post new topics in this forum