"Keep Remote Directory..." ignores "Maximal number of transfers" resulting in 1/6 DL speed

Advertisement

yupowert
Joined:
Posts:
2

"Keep Remote Directory..." ignores "Maximal number of transfers" resulting in 1/6 DL speed

Using the regular interface I drag/drop folders onto remote SFTP directory. I have it configured for a maximum of 9 file copy "threads". I get ~95Mbps transfer. (taking about 28hrs to complete my regularly updated files). 95Mbps is saturating my internet upload link to 100% - perfect!

Using the "Keep Remote Directory up to date" option I only get ~15Mbps - presumably because it's only transferring files using 1 file copy thread. (which would take 1 week! to complete)

This has to be a bug/design flaw?

Surely the "Keep Remote Directory" option should just feed the updated file sync requests to the main WinSCP background file handler, which would obey all the options such as "Maximal number of transfers".

ps. Using the normal file handler would also display much better file stats - currently when "Keep Remote Directory" is in use, the tiny log window displayed is utterly useless. It cannot be resized or scrolled as the modal info dialog box in front of it prevents access. All I ever see is a timestamp and the first half of a files directory path - completely pointless.

Many thanks

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
31,624
Location:
Prague, Czechia

Re: "Keep Remote Directory..." ignores "Maximal number of transfers" resulting in 1/6 DL speed

It's not a bug. It behaves as implemented.
It can be improved, no doubt.

Reply with quote

yupowert
Joined:
Posts:
2

OK.

Would you like me to re-post it in feature requests - or move it - or - something. Just so that it's noted, and added as feature request #32768

Many thanks

Reply with quote

Advertisement

You can post new topics in this forum