Cosmetic bug - on Windows 8, shortcut icons are not displayed

Advertisement

ks
Donor
ks avatar
Joined:
Posts:
89
Location:
Moscow

Cosmetic bug - on Windows 8, shortcut icons are not displayed

WinSCP 5.15 does not show icons for shortcuts/folders in Windows 8. After some testing I found out it's more than that - WinSCP actually can randomly display some of the icons, if you enter the same dir once again. Somehow, it selects only some of the shortcuts to display icons for. And if I close WinSCP and relaunch it, it forgets about then and shows no icons again.

Another example: when I launch it and the local dir is C:/Temp, it may show folder icons for about half of the folders that are there. Now if I get out of the dir and then back in, it now displays icons for all of the folders.

And it's all Ok on Windows 7.

no-icons-2.png

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
31,808
Location:
Prague, Czechia

Re: Cosmetic bug - on Windows 8, shortcut icons are not displayed

ks wrote:

WinSCP 5.15 does not show icons for shortcuts/folders in Windows 8.
So were it working in earlier versions of WinSCP?

Another example: when I launch it and the local dir is C:/Temp, it may show folder icons for about half of the folders that are there. Now if I get out of the dir and then back in, it now displays icons for all of the folders.
How long does it take to open that folder?

Reply with quote

ks
Donor
ks avatar
Joined:
Posts:
89
Location:
Moscow

Yes, it used to work correctly. I tested older portable versions.
4.3.4, 5.1.8, 5.5.1, 5.7.1, 5.7.2 are just fine.
5.7.3 and higher, 5.9, 5.9.1, 5.11 show some icons, but not all anyway (see the image). This may be related with "Optionally determining local file icon by extension only" from https://winscp.net/eng/docs/history?a=5.7.3

5.14.2 and higher, to 5.15, do not show icons of regular folders (local panel on the left side) when WinSCP starts with that folder open (5.14.1 doesn't have this bug). As the folder is local, it shows it immediately. On the second entry, folder icons are usually displayed, but I saw a case when 1 folder icon was not displayed even then, but when I reentered again, it was displayed finally.

The last bug may be related to "Loading .exe (and similar) file icons asynchronously" from https://winscp.net/eng/docs/history?a=5.14.2

I also tried the hidden configuration option Interface\LocalIconsByExt, it didn't help.

not all icons.png

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
31,808
Location:
Prague, Czechia

I do not think that any change in 5.7.3 could have caused the difference.
Unless you actually had the Interface\LocalIconsByExt set before.
Did you try to turn it off?

For the 5.14.2 problem, it's more likely related to
https://winscp.net/tracker/1709

I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

ks
Donor
ks avatar
Joined:
Posts:
89
Location:
Moscow

I never used Interface\LocalIconsByExt before, only tried it once.
Now I have tested it again, and Interface\LocalIconsByExt=0 helped with folders only (5.14.2 bug).

Last edited by ks on 2019-08-19 13:29; edited 1 time in total

Reply with quote

Advertisement

ks
Donor
ks avatar
Joined:
Posts:
89
Location:
Moscow

martin wrote:

For the 5.14.2 problem, it's more likely related to
https://winscp.net/tracker/1709
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.
As I wrote in the email, the debug version didn't fix the 5.3.7 problem, but it fixed the 5.14.2 one.

As for 1709, I had no crashed, and anyway, I don't see what use is in the fact that the problem is related to another problem.

Reply with quote

ks
Donor
ks avatar
Joined:
Posts:
89
Location:
Moscow

martin wrote:

I do not think that any change in 5.7.3 could have caused the difference.
Well, I tested all versions of WinSCP one by one (portable, of course) and found exactly the border where the bug shows up. Also, I found an item in the changes history that is related to icons at least. Can't be a coincidence, right?

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
31,808
Location:
Prague, Czechia

Re: Cosmetic bug - on Windows 8, shortcut icons are not displayed

While I was not able to identify the problem yet, I'm at least allowing to turn off the behaviour that causes the problem for unknown reasons.
https://winscp.net/tracker/1783

Reply with quote

ks
Donor
ks avatar
Joined:
Posts:
89
Location:
Moscow

Great, will try it when 5.16 is released.
Installed the WinSCP-20190905rsergei-Portable.zip build now.

Reply with quote

Advertisement

You can post new topics in this forum