WinSCP-5.15.3-Automation.zip winscp.exe and winscpnet.dll have a mismatch

Advertisement

Guest

WinSCP-5.15.3-Automation.zip winscp.exe and winscpnet.dll have a mismatch

I've downloaded and unpacked these two files together and get the following message when used:
winscp.exe (5.13.3.0) does not match version of this assembly WinSCPnet.dll (5.7.7.0)

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
32,073
Location:
Prague, Czechia

Re: WinSCP-5.15.3-Automation.zip winscp.exe and winscpnet.dll have a mismatch

When do you get that error?

Reply with quote

craigdanforth
Joined:
Posts:
1

WinSCP Version 5.15.2 (Build 9590) Error Mismatched errors with WinSCPnet.dll

WinSCP Version 5.15.2 (Build 9590). When I run a powershell script and get to my
Add-Type -Path "C:\Program Files\WinSCP\WinSCPnet.dll" I get an Error: Could not load file or assembly 'file:///C::\Program Files\WinSCP\WinSCPnet.dll' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded. The WinSCPnet.dll is dated 5/29/2019.

When use a different WinSCPnet.dll dated 1/8/2019 the error changes to: Exception calling "Open" with "1" argument(s): "The version of C:\Program Files\WinSCP\winscp.exe (5.15.2.0) does not match version of this assembly C:\Program Files\WinSCP\WinSCPnet.dll (5.13.7.0)."
How do I find the WinSCPnet.dll that works with winscp.exe (5.15.2.0)?

Reply with quote E-mail

Advertisement

You can post new topics in this forum