Cannot transfer files with german umlaut

Advertisement

cmos12345
Guest

Cannot transfer files with german umlaut

I know there have been many topics here about problems with german umlauts. But I didn't find any solution for my issue so far.

We're trying to transfer a file with the german umlaut 'ä' in the filename using the .NET library of WinSCP via SFTP.
When opening the WinSCP UI, the filename is also not displayed correctly. There will be a '?' instead of 'ä' in the filename.

We tested with every of the UTF flags in WinSCP without success, but we were able to transfer the file using Filezilla, so the server seems to support UTF.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
31,598
Location:
Prague, Czechia

Re: Cannot transfer files with german umlaut

Please attach a session log file (and FileZilla verbose log).

Reply with quote

cmos12345
Guest

Re: Cannot transfer files with german umlaut

We managed to transfer the files via winSCP client now (there was a problem with the server)

We use a pretty old version of winSCP at this particular client.

How do we set UTF flag in our code, when we do not have session.AddRawSetting available?

Reply with quote

Helvetica
Donor
Joined:
Posts:
4
Location:
Switzerland

Just for information - using Umlaute or French accents in file names can cause a lot of errors in your log. I accidently uploaded some files using the word Babelon_Traité_(number).jpg and txt and I found literally hundreds of error reports in my server log and google's log.
Perhaps it may be easier to use ae for ä, ue for ü, oe for ö etc. if your files are accessible to the public.

Reply with quote

Advertisement

You can post new topics in this forum