Topic "Host has not answered for 15 seconds"

Author Message
giffyd
[View user's profile]

Joined: 2006-01-19
Posts: 3
Hi,

I'm using the synchronization feature of WinSCP on some Windows XP laptops which connect to a Windows XP WinSCP box. The synchronization feature is run via a script which I keep the logs.

Some users have the following in there log file:

Host has not answered for 15 seconds.
Wait for another 15 seconds? Pressing 'Abort' button will close session.
(A)bort, (R)etry: Abort

Why does this happen? How can I prevent it from happening?

Thanks.
Advertisements
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Have you tried setting longer timeout?
_________________
Martin Prikryl
aadami

Guest


How can I automatically define the answer as abort? The problem for me is that I am running a script early in the morning without any user intervention, and the retry or abort questions is making the console to stay open.
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
aadami wrote:
How can I automatically define the answer as abort? The problem for me is that I am running a script early in the morning without any user intervention, and the retry or abort questions is making the console to stay open.

Have you tried "option batch abort"?
_________________
Martin Prikryl
Piotrek

Guest


Would you mind telling me how to change timeout with WinSCP script? I've tryed "option batch off" - script doesn't respond even when external command had finished it's tasks (until I press "R").
"option batch retry" - unkown option..
"option timeout 1000" - unkown option..
How to avoid this message:?:
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
Piotrek wrote:
Would you mind telling me how to change timeout with WinSCP script? I've tryed "option batch off" - script doesn't respond even when external command had finished it's tasks (until I press "R").
"option batch retry" - unkown option..
"option timeout 1000" - unkown option..
How to avoid this message:?:

This FAQ will give you hopefully some idea how to do that.
_________________
Martin Prikryl
jamescarpino

Guest


prikryl wrote:

This FAQ will give you hopefully some idea how to do that.


Martin,
This feature has caused me great agony and wasted minutes. Of course having your program in the first place has caused me great convenience and saved lots of time, but I think there is a basic mistake here that causes people a lot of pain.

Why not just automatically retry by default? Why not reconnect by default? It is the internet after all. Many people have unreliable networks, and a longer timeout isn't going to help. I waste so much time because what I told the program to do, it didn't do when I get back to the computer. I may get this error 20 or 30 times in a single batch. I spend my life clicking "Retry". I am trying to decide whether to go back to Cygwin command line, because using regular SCP -R just never has exhibited this problem.

Thanks,
James
martin
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 25034
Location: Prague, Czechia
jamescarpino wrote:
Why not just automatically retry by default? Why not reconnect by default?

It will be solved in the next version.
_________________
Martin Prikryl
Advertisements

You can post new topics in this forum






Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!

Donate

About donations

$9   $19   $49   $99

About donations

Recommend

WinSCP Privacy Policy

WinSCP License