5.16 beta 4.0 Framework DLL not signed

Advertisement

chrislong2
Joined:
Posts:
19
Location:
USA

5.16 beta 4.0 Framework DLL not signed

Hi Martin,
I noticed when downloading the 5.16 beta package that the WinSCPnet.dll for the 4.0 framework is not signed (strong named) whereas it has been in the past. I see there was a similar issue posted a few versions ago which you fixed but it seems to have happened again?
Thanks,
Chris

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
31,935
Location:
Prague, Czechia

Re: 5.16 beta 4.0 Framework DLL not signed

I've checked and I believe that the WinSCPnet.dll in the WinSCP-5.16.beta-Automation.zip package is signed.

Can you recheck? If you still find the assembly not to be signed, please post some evidence.

Reply with quote

chrislong2
Joined:
Posts:
19
Location:
USA

The one in the "netstandard2.0" subfolder is signed, but the one in the "net40" subfolder and the same net 4.0 one in the main folder are both not signed. I've just double-checked. Just right-click on it and notice the absence of the Digital Signatures tab.

Also, while I've got you - 2 questions: (1) I noted in changelog that it now targets the 4.0 framework. The install instructions still reference that it works on 2.0 framework. Will it still work on the 2.0 framework (not 2.0 standard, I mean the actual 2.0 framework) if 4.0 is not installed? (2) Do you have any guess as to when 5.16 might get out of beta?

Thanks Martin!

Reply with quote

Advertisement

You can post new topics in this forum