Image corruption with keepuptodate

Advertisement

p0630034
Joined:
Posts:
5
Location:
Australia

Image corruption with keepuptodate

Hi,

Using task scheduler to call WINSCP to sync a folder to a remote FTP site with keepuptodate. We noticed today that some .jpg files were corrupted on the remote end while it could be open locally. I've read through a couple of forum posts regarding setting the transfer mode to binary and I've done that since I set this up.

Just wondering if anyone else has faced this issue before even with binary mode turned on. Below is the argument line I used.

/ini=nul /log="C:\Logs\imagessync.log" /logsize=5*10M /command "option batch continue" "option confirm off" "open ftps://username:password@ftpsite -explicit" "keepuptodate -transfer=binary -resumesupport=on -delete ""D:\folder\images"" "/images""

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
31,935
Location:
Prague, Czechia

Re: Image corruption with keepuptodate

Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, use /log=C:\path\to\winscp.log command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

p0630034
Joined:
Posts:
5
Location:
Australia

Ok. Will monitor. It hasn't happened yet since I updated to the latest version. Client also hasn't synced large batches of images since. Will post back when I have logs.

Reply with quote

Advertisement

You can post new topics in this forum