Every version greater than 5.13.9 takes very long to start - enterprise - DFS scanning issue

Advertisement

Wedman
Joined:
Posts:
2
Location:
Germany, Munich

Every version greater than 5.13.9 takes very long to start - enterprise - DFS scanning issue

Dear friends in this community,
we use WinSCP in a huge enterprise environment with Windows10-1803 x64 Clients. I'm observing in every newer Version till 5.16RC2 since our good working Version (5.13.9), that the start of the application will take round about 1 Minute, sometimes above. I had the hope, that this will be noticed by the dev-team itself, but now I thinkt it don't. Thats the reason why I wasn't able to update the application with a newer Version here, but I want :-)

I tried to analyze the the issue now by myself. With precess monitor (sysinternals) I saw, that the process WinSCP.exe is browsing or scanning through our whole DFS-root-structure, where the users home-share lies. I think thats the root cause, because there are more than 60 thousands (!) users homeshare puplished. Please see attachment

Can you analyze the malfunction? If you have a debug version for more logging stuff, please feel free to contact me.

Thanks in Advance, best wishes
Andreas

Description: Process_Monitor showing WinSCP scanning through DFS-structure

WINSCP_Browsing_DFS_HOME.png

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
32,052
Location:
Prague, Czechia

Re: Every version greater than 5.13.9 takes very long to start - enterprise - DFS scanning issue

What has changed in 5.14 is that the main WinSCP window opens behind the initial Login dialog, with users documents folder opened in the local panel. If the documents folder is within a huge tree like yours, it can take long to display, indeed.

I assume you actually do not use that folder, otherwise even the older versions of WinSCP would take long to display (after login).

In the latest version of WinSCP, if you navigate away from that folder (or even after you login to your session, which presumably has a different local folder set as default) and close WinSCP, the next time you start it, it should open on that folder (and consequently quickly).
Can you confirm that behavior?

Anyway, I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum. We can try to debug the loading and make it quicker.

Reply with quote

Wedman
Joined:
Posts:
2
Location:
Germany, Munich

Re: Re: Every version greater than 5.13.9 takes very long to start - enterprise - DFS scanning issue

Hello Martin,
as already written to you with PN, I think I really found the mistake. In the winscp.ini there was a line present "LastPath" pointing to an UNC-Share of "My documents", because we use group policy with folder redirection of these real profile folders to a network share (home drive of the user) with an UNC path.

It seems that old WinSCP 5.13.9 ignores this not supported UNC-Path-setting, so there is no issue at Startup, and so we didn't notice this in the past. Newer WinSCP versions are supporting UNC pathes, so now this setting is suddenly valid, and WinSCP is checking the availability of "my documents" on our DFS-infrastructure leading to the startup issue.

The solution is now for me at the moment, to configure out this disruptive setting in the Winscp.ini and to inform our users to change in the upper left corner within the gui (drop down) the last used folder away from "my documents" to a really mapped (network) drive.

Perhaps you will see some additionally improvements in the Code, too.

Thanks for your help and best wishes

Reply with quote

Advertisement

You can post new topics in this forum