Shell incompatibility error only after 5.17 update, previous version work fine with BASH

Advertisement

cmsharp27
Joined:
Posts:
2
Location:
Frederick, MD

Shell incompatibility error only after 5.17 update, previous version work fine with BASH

I just updated to 5.17 and when connecting to our gateways, we get the error message "Error skipping startup message. Your shell is probably incompatible with the application (BASH is recommended.)" This is normally where I would have to go in and change the shell to bash, but I have confirmed the shell is set to bash. I grabbed the 10.15 portable and am able to connect to these same servers via bash without issue. Protocol is SFTP, port 22. Screen capture attached. Remote gateways are running on a 2.6 kernel. Not pressed for a fix since I can use an older portable but wanted to let you know.

5.17scp error.PNG

Reply with quote

Advertisement

jmcclain
Joined:
Posts:
2
Location:
United States

I'm getting the same error message with SFTP with "Allow SCP fallback" enabled.
The exact same configuration works fine with version 5.15.9.

Edit: Changing the Shell from "Default" to "/bin/bash" fixes it.
Alternately, manually choosing SCP as the File protocol works as well.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
33,710
Location:
Prague, Czechia

Re: Shell incompatibility error only after 5.17 update, previous version work fine with BASH

Can you post a log file of a failing connection from 5.17 and the same working connection from an older version?

Reply with quote

KevinS
Joined:
Posts:
1
Location:
Germany

Re: Shell incompatibility error only after 5.17 update, previous version work fine with BASH

We have the same issue. Chaging the shell to "/bin/bash" works, but has to be done for every single connection. Our logs are attached.
  • WinSCP_5.17.log (19.46 KB, Private file)
Description: (sensitive data censored)
  • WinSCP_5.15.9.log (50.48 KB, Private file)
Description: (sensitive data censored)

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,710
Location:
Prague, Czechia

Re: Shell incompatibility error only after 5.17 update, previous version work fine with BASH

Thanks for the logs and all the reports.

This issue has been added to the tracker:
https://winscp.net/tracker/1827

I'm sending you an email with a development version of WinSCP to the address you have used to register on this forum.

Reply with quote

jmcclain

5.17.1 SCP Fallback Fix Works!

Sorry for taking so long to reply back, I didn't test the dev build you sent but I did just update to the latest stable version of WinSCP (5.17.2) and the issue with SCP fallback appears to be resolved. Thanks for implementing the fix so quickly!

Reply with quote

Advertisement

You can post new topics in this forum