Stop appending directory name to session tab

Advertisement

teaelleceecee
Joined:
Posts:
2

Stop appending directory name to session tab

I recently upgraded my WinSCP (to v. 5.17.1) after using an old version for a long time. One of the new changes appears to be naming of session tabs - instead of appending a number in brackets to each session tab from the same site, WinSCP now appends the name of the directory open in the tab.

I can see the appeal of this, however, a lot of the directories I work with have really long names and this quickly takes up the space at the top of the window. I could not find a workaround in the settings (please let me know if there is one!) so instead, I went about renaming my session tabs by right clicking on them and choosing 'Rename Session'. This actually worked ok except now when I load a saved workplace with renamed tabs, WinSCP asks me for a password each time I reconnect to a renamed tab, even though I have my passwords saved. It does not ask me for a password if I reconnect to a tab that has not been renamed.

Can anyone please help me? Is there a way to stop WinSCP appending the directory name to the session tab? And if not, is there a way to get WinSCP to stop asking me for a password when reconnecting to a renamed tab (i.e. like when trying to load a saved workplace). Thank you for your help!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,710
Location:
Prague, Czechia

Re: Stop appending directory name to session tab

Sorry for my late answer. I took me while before I got time to try to reproduce the problem with passwords. But I did not succeed. Can you provide us step-by-step instructions for reproducing the problem?

Dump of workspace registry entries might help too.
HKCU\Software\Martin Prikryl\WinSCP 2\Sessions\workspacename/000x

Reply with quote

teaelleceecee
Joined:
Posts:
2

Re: Stop appending directory name to session tab

Brilliant - deleting the workspace registry entries and starting again seems to have solved the password issue. Thank you for your help.

I'm not sure what caused the password issue in the first place, but having the path as the session name as an option rather than a compulsory feature would prevent it from ever happening again. Others seem to have issues with this new system too (https://winscp.net/tracker/1734) - being able to turn it off or on means both camps would be happy.

I acknowledge developing, maintaining and enhancing WinSCP is a big job, thank you so much for your work, and thanks again for your help.

Reply with quote

Advertisement

You can post new topics in this forum