Topic "Cannot change file ownership"

Author Message



when using WinSCP to connect to a Solaris 8 system (as root), I cannot change any file ownership to, say, the user which Apache is supposed to use (see example below). Those fields in the GUI are grayed out. However, when connecting directly via SSH, I can use chown to set the file ownership without problems. I tried this with version 3.5.6 (Build 213) as well as version 3.7.1.
I am not sure what exactly it is that causes this behavior, but as it works in a terminal, I tend to assume that it's a WinSCP thing. Any hints?


As it is:
-rw-r--r-- 1 root other 58813 Jan 18 13:50 file_2.jsp

As it should be:
-rw-r--r-- 1 www www 58063 Jan 16 15:32 file_3.jsp
[View user's profile]
Site Admin
Joined: 2002-12-10
Posts: 26299
Location: Prague, Czechia
Please read FAQ.
Martin Prikryl


Ok, RTFM would have solved my problem, I guess.
Sorry for being so stupid.

You can post new topics in this forum

Search Site

What is WinSCP?

It is award-winning SFTP client, SCP client, FTPS client and FTP client integrated into one software program for file transfer to FTP server or secure SFTP server. [More]

And it's free!


About donations

$9   $19   $49   $99

About donations


WinSCP Privacy Policy

WinSCP License