Can't see selected files in commander mode

Advertisement

ryfi
Guest

Can't see selected files in commander mode

When using commander mode, I cant use ctrl/shift to select files. When I switch it to Explorer it works fine.

Another weird quirk is when I select multiple files (even though I can't see the selection), when I right click and edit, then switch back to WinSCP I can see the selection. It can't be changed though.

Reply with quote

Advertisement

ryfi
Joined:
Posts:
3

I'm using the latest version as of the time of this post. This bug happened when I upgraded to a new version a few months ago, but I forget what the version change was.

I'm using a 4K monitor with 150% scaling.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
33,846
Location:
Prague, Czechia

Re: Can't see selected files in commander mode

ryfi wrote:

When using commander mode, I cant use ctrl/shift to select files. When I switch it to Explorer it works fine.

Another weird quirk is when I select multiple files (even though I can't see the selection), when I right click and edit, then switch back to WinSCP I can see the selection. It can't be changed though.
Thanks for your report.
So can you or cannot you select the files? Is the problem only about seeing the selection or actually selecting the files? Can you post few screenshots documenting the problem?

Reply with quote

ryfi
Joined:
Posts:
3

It seems to be selecting the files, but not visually showing me that in any way. It's basically impossible to use commander mode.

This has been tested on about 5 different PCs, but the same portable install on all of them.

When I grab a new portable version fresh without my settings file, the selecting works just fine.

This is a screenshot of me selecting the bottom 3 files in a FRESH portable version:



(I know the selection is faint but it's there...)

This is a screenshot of me selecting the bottom 3 files in MY portable version:



Note that immediately after taking the screenshot, my selection became visible. Hiding WinSCP behind something and revealing it again also reveals my selection.

Hopefully this helps. Let me know if I can provide any other info.

Reply with quote

Advertisement

ryfi
Joined:
Posts:
3

I managed to solve the problem by replacing the Interface/Commander sections of my config file with a stock one.

I've included the original section of the config that I replaced in case you want to look into how it possibly happened.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
33,846
Location:
Prague, Czechia

Thanks. Unfortunately, even with your configuration, the selected works as expected for me.

Btw, is your screenshot with the selection visible for an active or a passive panel? I get this dark selection for the passive panel only. For the active, the selection is dark blue.
As here: https://winscp.net/eng/docs/screenshots#dark

Reply with quote

Advertisement

You can post new topics in this forum