Enable PTY ?

Advertisement

ohyes
Joined:
Posts:
3

Enable PTY ?

Hi,
I must connect to a server via putty using -t option ('enable PTY').
Connecting to this server does not work, I guess because I did not pass -t option.
How can I pass this option to WinSCP?
Thanks!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,516
Location:
Prague, Czechia

Re: Enable PTY ?

PTY is mutually exclusive to SFTP/SCP protocols.
Why do you need PTY to connect?

Reply with quote

ohyes
Joined:
Posts:
3

"Why do you need PTY to connect?"
I tried to connect to the server with putty and without '-t', but it does not work. The option -t is mandatory for this server.
No chance to add this option in WinSCP ? Or do you know an alternative ?
Thanks.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
33,516
Location:
Prague, Czechia

Once again, PTY is mutually exclusive to SFTP/SCP protocols. In other words, no SFTP nor SCP client can ever work with a server that does not allow connections without a terminal emulation. It has nothing to do with WinSCP.

If you want us to help you further, please provide more details than "it does not work".

Reply with quote

ohyes
Joined:
Posts:
3

Here is the error I get when I ommit -t:
$ ssh user@@ssh.server.com /bin/bash
password: xxx
FS Error: ssh must be used with the -t option to enable PTY

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum