Folder permissions

Advertisement

phred2u
Joined:
Posts:
5
Location:
Toronto

Folder permissions

I've set the folder permission and default permissions but they always revert back which prevents the files from being available to the service that tries to read them. I'm using 5.17.3 build 10325 and the error received when the scheduled job tries to run is:

Task status: Downloading error
Problem description: There was an error downloading the file from the SFTP server.
Start date: ---

How can I set the folder permission so they stay set?
Thanks.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,516
Location:
Prague, Czechia

Re: Folder permissions

How do you set the permissions? On what occasion do they revert? Why do you think it's WinSCP issue?

Reply with quote

martin
Site Admin
martin avatar

phred2u wrote:

I've set the permissions with transfer settings and on the individual folders. When I relaunch, the changes are gone.
What do you relaunch? Please post some log files documenting the problem.

Reply with quote

phred2u

Relaunch - restart the app same day or a new day, the preferences I set when I last ran the program get reset. I see no menu option to download log files.

Reply with quote

Advertisement

martin
Site Admin
martin avatar

So the permissions are correct one day. You close WinSCP. And when you start WinSCP the other day, they are wrong, correct? So do I understand, that the permissions reset, while WinSCP is not running? Then it does not look like a WinSCP problem.

Reply with quote

phred2u

Let me ask this another way; how to i get the winscp folder permissions to be retained at the permission i set them at? I have a service running every day and it isn't being allowed to read the file because the folder settings keep reverting back to what winscp wants them to be.

Reply with quote

martin
Site Admin
martin avatar

Those are not "winscp" folder permissions. Those are permissions of files on the server. If your server is resetting the permissions overnight, no WinSCP setting can fix that. Please talk to your server administrator.

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum