https://winscp.net/schema/session/1.0

Advertisement

Marlonrea
Joined:
Posts:
4
Location:
Toronto, ON

https://winscp.net/schema/session/1.0

Hello,

We have recently started using the XML logging. When validating the schema its appears the Owner tag has a minor issue, see below.
76:43 schema.xsd src-resolve: Cannot resolve the name 'owner' to a(n) 'element declaration' component.
1:1 sample.xml Premature end of file.

What we are trying to accomplish is using xml logging file within our middleware to alert the team if any failures.

Please help with the above issue, thank you a head of time.

2020-05-02_7-51-23.png

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
36,227
Location:
Prague, Czechia

Re: https://winscp.net/schema/session/1.0

Sorry, I do not understand what does the screenshot show. What exactly are you doing? How can I reproduce that? I do not see any owner at (or around) the line 76 of session_1.0.xsd.

Reply with quote

Marlonrea
Joined:
Posts:
4
Location:
Toronto, ON

Re: https://winscp.net/schema/session/1.0

Martin,

When validating the schema the errors shown in the screenshot are saying "Owner"ve: Cannot resolve the name 'owner' to a(n) 'element declaration' component.

Seems it not being declared which makes it a none valid xsd.

Reply with quote

Marlonrea
Joined:
Posts:
4
Location:
Toronto, ON

Hi MARTIN,

Thank you but still appears to be an issue when validating.

Error - This schema doesn't appear to be valid by itself (as part of another schema, it might still be ok)
DTD/Schema error - element 'owner' is undefined.

Reply with quote

Advertisement

Marlon
Guest

XML error logging

Hello,

When I have enabled the XML logging for errors within any WINSCP script that we are running seems the structure is different for all the WINSCP connections we have established. I say this as we are using the schema as a reference to validate. I can say this as we see the below error
Expecting </message> got </session>

Reply with quote

Advertisement

martin
Site Admin
martin avatar

Re: XML error logging

Marlon wrote:

Expecting </message> got </session>
Can you show us the XML log that results in this error?

Reply with quote

Advertisement

You can post new topics in this forum