Default spreadsheet editor

Advertisement

roger68
Joined:
Posts:
2

Default spreadsheet editor

I am having a problem opening spreadsheets from WinSCP. I had both open office and Microsoft Office installed, at that point WinSCP was opening excel files with Open office, I want to use MS Office instead. I downloaded the spreadsheet in question, used "Open With" to open the file and set "always use this application" to set excel as the default app, WinSCP still uses Open Office however. I rebooted the computer, same deal. I then uninstalled Open Office, now when I try to open a spreadsheet WinSCP gives me an error:

"System Error. Code: 2. The system cannot find the file specified".

I can download the file so it is indeed there and has no issues, when I open the file I downloaded excel does open and the file is fine.

WinSCP is obviously not getting the proper default app settings from Windows (10 Pro). I am wondering if there is a way to set the default applications in WinSCP?

My last resort effort would be to uninstall WinSCP and reinstall, however, I am concerned about losing all of the FTP sites I have setup? Short of being able to select default apps to open files, can someone confirm if my sites will be wiped if I uninstall WinSCP? If so, is there a way to export the site settings so I can import them after re-installing?

Thanks in advance to anyone who can help me out with this!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,516
Location:
Prague, Czechia

Re: Default spreadsheet editor

Do you have any specific rules for Excel files in WinSCP editor preferences?
https://winscp.net/eng/docs/ui_pref_editor

Reinstalling WinSCP will hardly help.
Anyway to answer your question: When uninstalling, the uninstaller will ask you if you want to delete WinSCP settings and sites as well or not.

Reply with quote

roger68
Joined:
Posts:
2

Thank you for the reply.
Yes, I did have open office in the editors section. I had removed that and added excel but it started opening with notepad instead. After some poking around I realized the editor rules are processed in order from top to button, *.*=Notepad was above my excel rule so spreadsheets were opening in notepad. I dragged my excel rule to the top of the list and excel is opening now!
THanks again for your assistance.

Reply with quote

Advertisement

You can post new topics in this forum