Files deleted

Advertisement

josepfferrer@...
Guest

Files deleted

After the last update I notice that when I select files in the remote to drag to the local directory , istead of copy the selected files and delete the older in the local as I dis all the time, they just dissapear from the remot and are no longer avaiable...(???) and in the local remain the older version, can you imagin shuch frustation after hours of work in the remot....

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,516
Location:
Prague, Czechia

Re: Files deleted

Sorry, I'm not sure I understand. Are you saying that if you drag a file from the remote to the local WinSCP panel, the file does not get downloaded? But instead it gets deleted from the remote directory?

Reply with quote

Guest

Re: Files deleted

martin wrote:

Sorry, I'm not sure I understand. Are you saying that if you drag a file from the remote to the local WinSCP panel, the file does not get downloaded? But instead it gets deleted from the remote directory?

It occours when I select more than one file in te remote (in my case a Raspberry device) and drag and drop to my local directory, all those file are moving instead of copy, so they dissapear from my remote device.

Reply with quote

Guest

Re: Files deleted

martin wrote:

Are you dragging the files to the WinSCP local panel? Or somewhere else? What version of WinSCP are you using?

What are your "drag&drop" preferences?
https://winscp.net/eng/docs/ui_pref_dragdrop


Yes I'm dragging from my local panel , I have 5.17.15 version , I have never changed the default settings since the first versions I have used

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,516
Location:
Prague, Czechia

Re: Files deleted

Yes I'm dragging from my local panel
Do you mean "to" the local panel?

I have never changed the default settings since the first versions I have used
Can you show us your settings anyway?

Reply with quote

Guest

Re: Files deleted

martin wrote:

Yes I'm dragging from my local panel
Do you mean "to" the local panel?
My PC is the local , my Raspberry is the remot

I have never changed the default settings since the first versions I have used
Can you show us your settings anyway?

Well the Transfer is in Default mode, I can't see ayithing more. I have been doing allways the same procedure: select files in the remot(Raspberry Pi device) and drag and drop to the local ( my P.C.), I make this so automatically that I did't realize that files where moved to the local since I was trying to run the files from my Raspberry and I discovered that home/pi folder was empty...all the files were moved away, and I didn't change any option, just update every time the program advice me about new updates, so I was thinking that can be a change in the updated version. Now I look carefully every time that I drag files to avoid a unexpected file disaparitions. So if I detect something wrong I can explain better when happen. Thanks for your help

Reply with quote

Guest

Re: Files deleted

martin wrote:

I was asking for these settings:
https://winscp.net/eng/docs/ui_pref_dragdrop
Not for transfer settings.

the drag and drop is the first alternative selected : Determine drop target by dragging.....
Sorry, I start to think that is not a problem with the software , I work with my Raspberry device from my Tablet (win dows 10) trought VNC ,and just after some clicks of the mouse, it start to select erratycly , even the screen keyboard start to show wrong characters in the screen , not the one it correspond, I need to go out from the vnc screen and make some clicks in another program to return to the normality , but after some clicks in VNC starts the erratic behavior, may be in one of this erratic mouse behavior I use WinSCP to copy some files and everything got wrong...
This behavior don't appear in a normal P.C.

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum