script partially executes

Advertisement

cliffjl
Guest

script partially executes

I'm on windows 10 and the latest version of WINSCP. I'm just trying to GET and file using standard FTP protocol. It appears to connect and then end. I don't know how to proceed. Any ideas would be appreciated.

I'm running with a script. The command line is:
"C:\Program Files (x86)\WinSCP\winscp.com" /log="C:\TaxRates\WinSCP.log" /ini-nul /script=ftp.txt

The script is called ftp.txt and contains:
open ftp://user:Password@ftp.domain.xyz/
lcd C:\TaxRates\
get -transfer=ascii TAXRTECA.csv
exit

The winscp log file has this:
. 2020-07-02 14:45:46.517 Connecting to ftp.domain.xyz ...
. 2020-07-02 14:45:46.581 Connected with ftp.domain.xyz. Waiting for welcome message...
< 2020-07-02 14:45:46.635 220-#########################################################
< 2020-07-02 14:45:46.635 220-Please upload your web files to the public_html directory.
< 2020-07-02 14:45:46.635 220-Note that letters are case sensitive.
< 2020-07-02 14:45:46.635 220-#########################################################
< 2020-07-02 14:45:46.635 220 This is a private system - No anonymous login
> 2020-07-02 14:45:46.635 USER user
< 2020-07-02 14:45:46.688 331 User user OK. Password required
> 2020-07-02 14:45:46.688 PASS ************
< 2020-07-02 14:45:46.763 230-Your bandwidth usage is restricted
< 2020-07-02 14:45:46.763 230 OK. Current restricted directory is /
> 2020-07-02 14:45:46.763 SYST
< 2020-07-02 14:45:46.817 215 UNIX Type: L8
> 2020-07-02 14:45:46.817 FEAT
< 2020-07-02 14:45:46.871 211-Extensions supported:
< 2020-07-02 14:45:46.871 EPRT
< 2020-07-02 14:45:46.871 IDLE
< 2020-07-02 14:45:46.871 MDTM
< 2020-07-02 14:45:46.871 SIZE
< 2020-07-02 14:45:46.871 MFMT
< 2020-07-02 14:45:46.871 REST STREAM
< 2020-07-02 14:45:46.871 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
< 2020-07-02 14:45:46.871 MLSD
< 2020-07-02 14:45:46.871 AUTH TLS
< 2020-07-02 14:45:46.871 PBSZ
< 2020-07-02 14:45:46.871 PROT
< 2020-07-02 14:45:46.871 UTF8
< 2020-07-02 14:45:46.871 TVFS
< 2020-07-02 14:45:46.871 ESTA
< 2020-07-02 14:45:46.871 PASV
< 2020-07-02 14:45:46.871 EPSV
< 2020-07-02 14:45:46.871 SPSV
< 2020-07-02 14:45:46.871 ESTP
< 2020-07-02 14:45:46.871 211 End.
> 2020-07-02 14:45:46.871 OPTS UTF8 ON
< 2020-07-02 14:45:46.925 200 OK, UTF-8 enabled
. 2020-07-02 14:45:46.925 Connected
. 2020-07-02 14:45:46.925 --------------------------------------------------------------------------
. 2020-07-02 14:45:46.925 Using FTP protocol.
. 2020-07-02 14:45:46.925 Doing startup conversation with host.
> 2020-07-02 14:45:46.925 PWD
< 2020-07-02 14:45:46.979 257 "/" is your current location
. 2020-07-02 14:45:46.979 Getting current directory name.
. 2020-07-02 14:45:46.979 Startup conversation with host finished.
< 2020-07-02 14:45:46.979 Script: Active session: [1] user@ftp.domain.xyz
. 2020-07-02 14:45:46.979 Script: Exit code: 1
. 2020-07-02 14:45:46.988 Disconnected from server

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
33,846
Location:
Prague, Czechia

Re: script partially executes

Please attach a full session log file showing the problem (using the latest version of WinSCP).

Btw, it's /ini=nul, not /ini-nul

Reply with quote

cliffjl
Guest

full log file

Attached is the full WINSCP log file. It has several attempts in this file, so start at the bottom.
Description: full log file

Reply with quote

cliffjl
Guest

Works now

So I realized that I hadn't tested it with your observed problem: ini-nul should be ini=nul. I changed it to that and now it works. Thanks.

Reply with quote

Advertisement

You can post new topics in this forum