The version of exe does not match version of this assembly

Advertisement

tattdogg
Joined:
Posts:
19
Location:
Minsk, Belarus

The version of exe does not match version of this assembly

Hi guys

Exception message:
The version of C:\Program Files (x86)\WinSCP\5.17.3.0\WinSCP.exe () does not match version of this assembly F:\MyTask\WinSCPnet.DLL (5.17.3.0).

Stack trace:
WinSCP.ExeSessionProcess.CheckVersion(String exePath, FileVersionInfo assemblyVersion):260
WinSCP.ExeSessionProcess..ctor(Session session, Boolean useXmlLog, String additionalArguments):151
WinSCP.Session.Open(SessionOptions sessionOptions):944
MyTask.Core.FtpClient.get_Session():188

It looks like assembly cannot detect the version of executable file
I've checked both files (exe and dll) and the version for both is 5.17.3.0
I have lots of apps that can work with this exe file at the same time
This error occurs randomly

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
35,995
Location:
Prague, Czechia

Re: The version of exe does not match version of this assembly

Please attach a debug log file (Session.DebugLogPath).

Reply with quote

martin
Site Admin
martin avatar

Thanks. I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

Advertisement

kiranvm111
Guest

Re: The version of exe does not match version of this assembly

Are you able to find solution for this.
Please share the resolution

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
35,995
Location:
Prague, Czechia

Re: The version of exe does not match version of this assembly

kiranvm111 wrote:

Are you able to find solution for this.
Please share the resolution
Can you send me an email, so I can send you back a debug version of WinSCP to track the problem? Please include a link back to this topic in your email. Also note in this topic that you have sent the email. Thanks.

You will find my address (if you log in) in my forum profile.

Reply with quote

Advertisement

shagedorn
Joined:
Posts:
3

winscp.exe does not match version of the assembly

Since the update to version 5.17.10 we keep getting this error.
'The version of C: \ Program Files (x86) \ WinSCP \ winscp.exe does not match version of this assembly C: \ Program Files (x86) \ WinSCP \ WinSCPnet.dll (5.17.10.0). '
Sometimes it works and the next day it doesn't. It occurs quite arbitrarily.
Both WinSCP.exe and WinSCPnet.DLL are from version 5.17.10

We have completely uninstalled WinSCP. The complete registry cleaned up. Without success.
Before the update to 5.17.10 everything worked without any problems. Unfortunately we were forced to replace the old version 5.5.4.0.

Since it is probably the same error as described above, the question whether there is already a solution? We are grateful for every tip.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
35,995
Location:
Prague, Czechia

Re: The version of exe does not match version of this assembly

Please attach a full debug log file showing the problem (using the latest version of WinSCP).

To generate the session log file, set Session.DebugLogPath. Submit the log with your post as an attachment. If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

shagedorn
Joined:
Posts:
3

Hello Martin,

Thank you very much for your answer.

I am sending you 2 log files attached.

These are from the same system. This morning a file could be uploaded without any problems. This is the log debug-mmg_03032021.log.

An hour later another file should be uploaded. However, this failed due to the known bug. This is the log debug-mft_03032021.log

Nothing has changed during this time.
Just for information: Yesterday 2 uploads could be carried out without any problems.
Maybe you have an idea what else we can do.

Reply with quote

Advertisement

martin
Site Admin
martin avatar

Thanks. I've improved logging of the issue even more. Please try to reproduce the problem using a build I've just sent to your email address.

Reply with quote

Advertisement

You can post new topics in this forum