"Synchronize timestamps only" de-synchronizes instead

Advertisement

Guest

"Synchronize timestamps only" de-synchronizes instead

To reproduce:

- Run synchronize - timestamps only on a folder or on selected files
- Remote timestamp is now one hour ahead (e.g. local timestamp = 22:16:12, remote timestamp = 23:16:12)

- Now copy the same file to the remote directory
- Remote and local timestamps match!

Remote and local computer are in UTC+01:00 timezone. Remote is Debian Linux 3.1, local is Windows 98.

If there was an offset in both cases I would have said it's a configuration problem. But getting different timestamps from copy and synchronize looks more like a bug to me. Or am I missing something?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,469
Location:
Prague, Czechia

Re: "Synchronize timestamps only" de-synchronizes instead

I'll check it.
_________________
Martin Prikryl

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,469
Location:
Prague, Czechia

Can you tell me what version of WinSCP are you using? If 3.8, can you check if you have the same problem with older versions. And vice versa, if you use older version, can you check if you have the same problem with 3.8?
_________________
Martin Prikryl

Reply with quote

usch
Joined:
Posts:
7

Re: "Synchronize timestamps only" de-synchronizes instead

The about box says "Version 3.8.0 (Build 312)".

I just tried V3.7.6; that version seems to work ok.


(Edit: Reverting to an older version for synchronizing timestamps-only seems like a feasible workaround; I can live with that for the time being. Thanks for the hint.)

Reply with quote

Advertisement

You can post new topics in this forum