Open session in Putty (SSH) -> Username is escaped

Advertisement

cabadam
Joined:
Posts:
1

Open session in Putty (SSH) -> Username is escaped

I have reconfigured WinSCP to point to the ssh.exe now built in to Windows 10 rather than Putty (https://winscp.net/eng/docs/integration_putty#win32-openssh).
Many of our Linux machines I am connecting to are joined to our Active Directory domain. So, my username is "domain\username".

When WinSCP then launches ssh, the command line it sends the username as domain\\username (escaped with a double backslash). This then fails to authenticate.

I did find that if I use the other username format (username@domain) that then works correctly.

I see that the custom "prompt" value that can be past into the WinSCP setting has a setting to not escape it, but I don't see a way to do that with the username parameter. Is there a way for it to work with the domain\username format?

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
36,025
Location:
Prague, Czechia

Re: Open session in Putty (SSH) -> Username is escaped

Thanks for your report.

This issue has been added to the tracker:
https://winscp.net/tracker/1906

I'm sending you an email with a development version of WinSCP to the address you have used to register on this forum.

Reply with quote

Advertisement

You can post new topics in this forum