Synchronization does not exclude the directory it should exclude

Advertisement

tomtimen
Joined:
Posts:
2
Location:
Czech republic

Synchronization does not exclude the directory it should exclude

I am attaching a log that is self-explanatory. I am trying to do a synchronization local->remote so that the directory "voices" is excluded from the sync. As you can see in the log I have it in the filemask argument yet the tool still synchronizes this directory. It should not according to the documentation. Where is the problem, please?
  • scplog.txt (1.05 MB, Private file)

Reply with quote E-mail

Advertisement

tomtimen
Joined:
Posts:
2
Location:
Czech republic

Does not work either

Thanks but I tried that way too and it did not work either. I am on Windows as is apparent from the log file. I am sending another log file with the same problem using the corrected option like you suggested. It still does not work as you can see from the log.

I also tested with backslashes, did not work either.
  • scplog.txt (1.05 MB, Private file)

Reply with quote E-mail

Tomas
Guest

Does it get noticed?

I am not sure whether my reply in this thread will be seen by anybody or should I repost the topic once more as a whole? Not sure. Thanks for your first answer though, just wondering how to do it.

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
36,025
Location:
Prague, Czechia

Re: Does not work either

If you use an absolute path, it has to be a full path (and in the case of the synchronization, a full path to both local and remote directories). If you want relative, it has to start with a star:
synchronize remote -mirror ... -filemask=|*/voices/ ...
See https://winscp.net/eng/docs/file_mask#path
Or in this case, it's the same as if you name the directory only:
synchronize remote -mirror ... -filemask=|voices/ ...

Reply with quote

Advertisement

You can post new topics in this forum