End of line breaks not recognized

Advertisement

EmilyEmilyEmily
Guest

End of line breaks not recognized

Hi there, I'm receiving HL7 messages in a text file. The headers of each line are supposed to begin on new lines. However, I get lines wrapped when the files are downloaded. When I open text file by clicking on it from within the Winscp client to preview them, the line breaks are there. From what I understand, the 1252 ANSI-Latin 1 encoding is the default when opening files within the client.

When I download the file and open in notepad (I'm on windows server 2016), the lines are wrapped - no matter what I had set the transfer type to (binary or text). Maybe it is of interest to note that if I open the downloaded file in wordpad, the line breaks are there.

The problem is that I'm reading in the file using SAS (statistical analysis software), and I noticed that if the line breaks aren't showing up in notepad, they don't get recognized in SAS either.

Any guidance on how to troubleshoot this would be much appreciated, thanks.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
35,415
Location:
Prague, Czechia

Re: End of line breaks not recognized

What do you mean by "lines are wrapped"?
When you "open text file by clicking on it from within the Winscp client to preview them", where does it open? In WinSCP internal editor?
See also https://winscp.net/eng/docs/faq_line_breaks

Reply with quote

Advertisement

You can post new topics in this forum