Integration with windows terminal does not work

Advertisement

maroonmoon
Guest

Integration with windows terminal does not work

I followed the instructions as listed here to open ssh in windows terminal
https://winscp.net/eng/docs/integration_putty#wt

The windows terminal window opens ok, but I get an error [error 0x80070002 when launching `PASSWORD ssh.exe USERNAME@IPADDR -p 22 -t "cd /tmp/ ; /bin/bash"']
where PASSWORD, USERNAME and IPADDR are the values I am using.

If I uncheck the flag "Remember SSH password and pass it to putty", I get a ssh login prompt.
This is slightly inferior as I have to enter the ssh password, where as with putty, I don't.

It seems WinSCP is not forwarding the password correctly to Windows terminal, and hence it cannot execute the ssh command properly.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
34,943
Location:
Prague, Czechia

Re: Integration with windows terminal does not work

What the "Remember SSH password and pass it to PuTTY" does is that it adds the -pw password parameter to (putty.exe) commandline. Obviously it cannot work with wt.exe. So the behaviour you are getting it expected. Actually the Win32-OpenSSH section explicitly states that you need to turn the option off:
https://winscp.net/eng/docs/integration_putty#win32-openssh

You can override how the password is provided with the !P pattern. But I do not know if there is a way to provide a password to the Windows version of ssh.exe. See also https://stackoverflow.com/q/23419659/850848

As even the above question suggests, you can try to use WSL version of ssh with sshpass package. See also https://winscp.net/eng/docs/integration_putty#wsl

Reply with quote

Advertisement

You can post new topics in this forum