WinSCP fails to launch

Advertisement

monstuh
Joined:
Posts:
4
Location:
Texas

WinSCP fails to launch

Running into an issue where WinSCP will fail to launch consistently. Getting the following in Event Viewer:
Faulting application name: WinSCP.exe, version: 5.17.9.10905, time stamp: 0x00000000
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc000001d
Fault offset: 0x0001032a
Faulting process id: 0x169c
Faulting application start time: 0x01d6dd55917f0875
Faulting application path: C:\Temp\WinSCP-5.17.9-Portable_2\WinSCP.exe
Faulting module path: unknown
Report Id: 9fc5dc94-b219-4140-a801-9546814dff35
Faulting package full name:
Faulting package-relative application ID:
I have tried various version including the latest portable version, all with the same results.

Running this on Server 2016. If I attempt to launch the executable enough times, it does does but on the very next attempt, it fails.

From the minidump:
Exception Code: 0xC00001D
Exception Information: The thread tried to execute an invalid instruction.
Heap Information: Not Present
After further troubleshooting, found the issue appears with specific version of VMware Horizon View (7.10.3). Validated that with older versions of VMware Horizon, WinSCP loads without issue.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
36,025
Location:
Prague, Czechia

Re: WinSCP fails to launch

Thanks for your report.
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

monstuh
Joined:
Posts:
4
Location:
Texas

Re: WinSCP fails to launch

Thank you. Upon running the executable you provided, I am prompted with same Windows error message. Which is what I have encountered with the full / portable client. If I attempt to launch the executable enough times, the application does load successfully.

The attached log file is from a successful launch of the application and once it loads, I have no problems.

To clarify, the problem occurs when attempting to launch WinSCP. Functionality of the application is not an issue.

THR_2021.01.04_22h59m51s_001.png

Reply with quote

monstuh
Joined:
Posts:
4
Location:
Texas

Re: WinSCP fails to launch

Update... Got a workaround from VMware that resolved my issue.

The workaround essentially excludes WinSCP from hooking ftapihook32.DLL, the Serial Port and Scanner redirection, on the server.

In the Registry Editor, navigate to
HKLM\SYSTEM\CurrentControlSet\Services\ftsjail\ExcludeProcesses
Add *\winscp.exe
Restart

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum