Behaviour Changed in use, lost capability to read the server? Tried re-installing but cannot correct

Advertisement

Mr-uReka!
Joined:
Posts:
3
Location:
Online!

Behaviour Changed in use, lost capability to read the server? Tried re-installing but cannot correct

Hi Guys

A few weeks ago the entire behaviour of my WinSCP changed in an instant whilst using it? It stopped reading my Folder content.

I closed and reopened it, but the tree was still almost empty. See image! https://u-reka.club/misc/FTP-3.PNG This image compares my WinSCP view alongside my cPanel Filemanager view!

You can see a full list of Folders and Files in the 'root' of my Filemanager, but they are NOT visible in my WinSCP? It can now only see the 'ssl' and 'tmp' Folders? To view other content I now have to add the Path manually each time?

Also, it previously triggered 'Visual Studio Code' (VSC) to edit files. Now it just defaults to NotePad?

I have no idea what happened that day, maybe I slipped with the mouse and inadvertently changed the settings, but whatever happened it has not worked correctly since?

I have tried multiple times to uninstall and reinstall it, but it just comes back like this?

Any help to revert the behaviours back to as they were when first installed would be gratefully appreciated.

Thanks.

Mr-uReka!

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
35,731
Location:
Prague, Czechia

Re: Behaviour Changed in use, lost capability to read the server? Tried re-installing but cannot correct

I'm sure that those ssl and and tmp folder are completely different folders, just with the same names. You are probably in a wrong folder. Did you try to create the session from the scratch? So that it starts in the default folder of your account? Or did you try manually (by typing the path to "Open directory" box) go to /home/whatever?

Regarding the file editing: I do not know what happened, but you will probably have to configure your favourite editor again in preferences: https://winscp.net/eng/docs/ui_pref_editor

Reply with quote

Mr-uReka!
Joined:
Posts:
3
Location:
Online!

Behaviour Changed in use, lost capability to read the server? Tried re-installing but cannot correct

Hi, thanks for the reply.

I completely deleted everything, all sessions, workspaces, and even uninstalled wiping all trace of it from the PC, then reinstalled it, but it comes back like this as per after it messed up?

I would have tried rolling back to a restore point but then found it wasn't even turned on!

The only option I can think of is to restore the PC itself to factory and start again. But how tiresome to do that?

I can manually add Paths into the Bookmarks, but they just disappear from the Tree when you back out of them again.

I don't know what else to try?

Reply with quote

martin
Site Admin
martin avatar

Re: Behaviour Changed in use, lost capability to read the server? Tried re-installing but cannot correct

I'm sure this is not a local problem. No restore or reinstall will help. Either you have to navigate to some specific remote folder, to get to the location you see on the cPanel. Or something has changed/broke on the server. Or you are connecting to a wrong server or using a wrong account. Please talk to your hosting support.

Reply with quote

Mr-uReka!
Joined:
Posts:
3
Location:
Online!

Behaviour Changed in use, lost capability to read the server? Tried re-installing but cannot correct

OK, thanks for that suggestion to ask the Server Hosts, it turns out it was a bad cron job setup which was creating records every few minutes but they were not being deleted, so they built up over time to clog up the system, and the FTP Clients were timing out, hence causing them to stop reading the Server.

The Hosts delete them all of corrected the Crons so it shouldn't happen again, and WinSCP is now back to normal. Although it is still firing Notepad instead of Visual Studio still when I want to edit a file?

Thanks again for the help. Much Appreciated.

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum