WinSCP stuck at connecting?

Advertisement

rmi
Joined:
Posts:
1

WinSCP stuck at connecting?

Hi,

I setup a scheduled task a while ago to use WinSCP to upload files with SFTP, using the 'Generate Code' on the Transfer Options dialog, copied to a batch file. At first it worked fine, but all of a sudden it stopped uploading, and WinSCP.com/exe just hangs without doing anything it looks like, and the log file stops at line 7 with 'Process ID: <processid>'.

This also happens if I run the batch file my self. The funny thing is that 2 other users on the server can run the batch file and it works fine... If setting the scheduled task to run as either of those users it will not work and log file stops again at 'Process ID: <processid>'.

I also tried creating a new ad user, adding it to local administrators group on the server and running the scheduled task with it, and not working.

If I generate code in format 'Command-line', I can use that in a cmd window, but not in a batch file.

I have uninstalled it, removing everything and installed again, and still the same.

I hope anyone have an idea of why this happens and how to fix it...

Output of logfile:
. 2021-07-06 18:18:36.429 --------------------------------------------------------------------------
. 2021-07-06 18:18:36.429 WinSCP Version 5.19.1 (Build 11552) (OS 10.0.14393 - Windows Server 2016 Datacenter)
. 2021-07-06 18:18:36.430 Configuration: nul
. 2021-07-06 18:18:36.430 Log level: Debug 2
. 2021-07-06 18:18:36.430 Local account: SERVER\Administrator
. 2021-07-06 18:18:36.430 Working directory: C:\FTPUpload
. 2021-07-06 18:18:36.430 Process ID: 14180

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
35,996
Location:
Prague, Czechia

Re: WinSCP stuck at connecting?

Thanks for your report.
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

Koukise
Joined:
Posts:
2
Location:
France

Hi
I got the same using WinSCP-5.19.1, I reverse back to a previous version.
Script was running OK in DOS cmd
Thank you

Reply with quote

martin
Site Admin
martin avatar

@Koukise: Thanks for your report.
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

pfrankli
Joined:
Posts:
1
Location:
US

Having the same issue

Upgraded to 5.19.1
Runs script via batch file
Intermittent hanging after process id. I can kill this process and run again and it will process normally.

Log:
. 2021-07-13 23:44:39.670 --------------------------------------------------------------------------
. 2021-07-13 23:44:39.670 WinSCP Version 5.19.1 (Build 11552) (OS 10.0.17763 - Windows Server 2019 Standard)
. 2021-07-13 23:44:39.670 Configuration: HKCU\Software\Martin Prikryl\WinSCP 2\
. 2021-07-13 23:44:39.670 Log level: Normal
. 2021-07-13 23:44:39.670 Local account: Domain\UserID
. 2021-07-13 23:44:39.670 Working directory: C:\ftp\files
. 2021-07-13 23:44:39.670 Process ID: 3680

Reply with quote

Advertisement

martin
Site Admin
martin avatar

Re: Having the same issue

@pfrankli: Thanks for your report.
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

Advertisement

You can post new topics in this forum