Can't navigate to directory after deleted and re-created

Advertisement

jhob
Joined:
Posts:
4
Location:
UK

Can't navigate to directory after deleted and re-created

WinSCP v5.19.1
Win 10 Pro build 19043

In a project I have a dist directory that I FTP to the server with WinSCP. When the project is built the dist directory is deleted and recreated with the build files.

If this directory is currently selected in WinSCP then it does not reappear in the file browser when recreated and cannot be navigated into when clicked on in the navigation pane.

I recorded a screencast to demonstrate the issue:
https://i.damselflycreative.com/ShareX/2021/07/AEUR4p1eai.mp4

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
36,025
Location:
Prague, Czechia

Re: Can't navigate to directory after deleted and re-created

Thanks for your report.
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

jhob
Joined:
Posts:
4
Location:
UK

Thanks Martin,

I tried replicating the issue with the debug version but it worked perfectly. The 'dist' directory reappeared in the navigation panel correctly and could be clicked on again in the files panel.

I tried the same operation again with my installed version and the bug persisted.

I've attached the log file anyway.

Reply with quote

jhob
Joined:
Posts:
4
Location:
UK

After this error occurred I opened a new session on a different site and on trying to download over FTP to a different directory, which had opened fine in the browser, I got the following error:
WinSCP was not able to detect folder, where the dragged file(s) was dropped
On restarting the application this download worked fine. It seems related to me.

WinSCP_Txc4iIfqZZ.png

Reply with quote

Advertisement

Advertisement

You can post new topics in this forum