Unable to get fingerprint starting v5.19.0

Advertisement

carlworks
Joined:
Posts:
2
Location:
Singapore

Unable to get fingerprint starting v5.19.0

Hi,

I'm not able to get the fingerprint and have this error below when I upgraded to v5.19.0 and v5.19.1.
Fingerprint for algorithm SHA-256 not supported
Below is my code:
string fingerprint = null;
// Host is not known yet. Scan its host key and let the user decide.
using (Session session = new Session())
{
    //Disable Version Check
    session.DisableVersionCheck = true;
    // Use the temporarily extracted executable
    session.ExecutablePath = executablePath;
    fingerprint = session.ScanFingerprint(sessionOptions, "SHA-256");
}
 
// Now we have the fingerprint
sessionOptions.SshHostKeyFingerprint = fingerprint;
Is this a bug or is there a new method that I should use?

Thanks and Best Regards,
Carl

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
36,266
Location:
Prague, Czechia

Re: Unable to get fingerprint starting v5.19.0

I'm quite sure that there was no change in 5.19.1 that could have caused this.
Are you sure you were using 5.19 before? Actually what version of WinSCP (not the assembly) are you and were you using? The DisableVersionCheck suggests that you actually do not use the same version of WinSCP and WinSCP .NET assembly, what is wrong.

Reply with quote

carlworks
Joined:
Posts:
2
Location:
Singapore

Hi Martin,

Thanks for your reply, I got an idea what is the cause of the problem. I forgot to update the executable in my resource location which caused the old version of WinSCP being created during runtime. Problem was fixed after I update the executable file with the latest version.

Thanks and Best Regards,
Carl

Reply with quote

Advertisement

You can post new topics in this forum