Using the command line interface – how to disable the listing of a remote directory?

Advertisement

JacksonM
Joined:
Posts:
3

Using the command line interface – how to disable the listing of a remote directory?

Hello all,

I was wondering if there was a way to have WinSCP bypass listing of a directory when connecting to a SFTP server? I'm using a command interface and can't find the switch to make it happen.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
36,283
Location:
Prague, Czechia

Re: Using the command line interface – how to disable the listing of a remote directory?

WinSCP lists the directory only when it needs to. Why do you think it does not in your case? Please attach a full session log file showing the problem (using the latest version of WinSCP).

To generate the session log file, use /log=C:\path\to\winscp.log command-line argument. Submit the log with your post as an attachment. Note that passwords and passphrases not stored in the log. You may want to remove other data you consider sensitive though, such as host names, IP addresses, account names or file names (unless they are relevant to the problem). If you do not want to post the log publicly, you can mark the attachment as private.

Reply with quote

JacksonM
Joined:
Posts:
3

Re: Using the command line interface – how to disable the listing of a remote directory?

It so happens that the SFTP server I'm connecting to kicks back an error every time WinSCP connects to it. WinSCP notes, "Error listing Directory" and, "Server returned empty listing for directory". I was hoping there was a command switch I can use to by pass WinSCP from trying to get a list of the contents of the folder. When clicking on the Help button on WinSCP it takes me to this URL which didn't give me info on what I can do:
https://winscp.net/eng/docs/message_empty_listing_for_directory

I have uploaded a edited version of the log per your request. The error in question is near the bottom of the log.
  • WinSCP_SDCITJM.log (7.19 KB, Private file)
Description: The error is near the bottom of the log.

Reply with quote

martin
Site Admin
martin avatar

Re: Using the command line interface – how to disable the listing of a remote directory?

1) It seems that your account home directory is inaccessible. Is that intended?
2) Your question was about "command line interface", while you have posted GUI log. So what is your actual problem?

Reply with quote

JacksonM
Joined:
Posts:
3

Re: Using the command line interface – how to disable the listing of a remote directory?

Hello Martin,

The issue is with getting WinSCP to bypass the listing of our vendors directory when using a command line. Our automated script fails at that point. From what our vendor noted their site doesn't allow for listing of the contents of the dirs. I was hoping there would be a switch I can use in a command line to by pass that type of dir listing.

I opened a ticket with our vendor on this issue as they noted they have clients that uses WinSCP, but so far they have not been of any help with answers. They just noted to ask WinSCP for help.

Reply with quote

Advertisement

martin
Site Admin
martin avatar

Re: Using the command line interface – how to disable the listing of a remote directory?

So can you post the log with your actual problem? = from the "commandline" use, not from GUI. So far, I do not even know that your real problem is.

Reply with quote

Advertisement

You can post new topics in this forum