help on the batch mode of scp3

Advertisement

toyoto
Guest

help on the batch mode of scp3

I have first try the scp version 3.8beta ,but at my computer,
the console mode shows "segement error" ;
so i try to use version 3.76 ;
and wehn i use my batch file like :
# Automatically answer all prompts negatively not to stall
# the script on errors
help
option batch on
# Disable overwrite confirmations that conflict with the option confirm off
# Connect using a password
# open user:password@example.com
# Connect
open root:something++@mysev
# Change remote direcory
cd /xxx
# Force binary mode transfer
put c:\tmp\data\*
# Disconnect
close
# Exit WinSCP
exit

===
it could not pass the authentication by the remote machine ;
but if i change the root passwd to "something with ++ at the tail" it could work.
so it seems that something is wrong concerning "the split of user name and its passwd "
Due to i have no BC 6.00 at hand , can any one help me to fix this problen.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,507
Location:
Prague, Czechia

Re: help on the batch mode of scp3

So it does work if the password has ++ at the end. And it does not work if the password is the verz same, just without the ++?
_________________
Martin Prikryl

Reply with quote

toyoto
Guest

So it does work if the password has ++ at the end. And it does not work if the password is the verz same, just without the ++?
Sorry for my mistype with ,i should mean without
the fact is
:when the passwd of remote machine is "somthing" ,I can login it by using the " open user:somthing@host"
But, when the remote machine change to "someting++", I cannot login again by using " open user:somthing++@host"
but in GUI mode i can enter in , so
may be some lexical analize problem with the batch mode where
parsing user:somthing++@host

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
28,507
Location:
Prague, Czechia

The connection string is treated as an SFTP/SCP URL address. For compatibility with browsers, plus sign is treated as a space. You need to URL-encode the plus sign to "%2B" as a workaround.
_________________
Martin Prikryl

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
28,507
Location:
Prague, Czechia

toyoto wrote:

:|
%2B still not work
the code is :
open root:123456%2B%2B@172.20.30.30
That's strange. I really do not have any more idea.
_________________
Martin Prikryl

Reply with quote

Advertisement

You can post new topics in this forum