New proxy prompt can be really frustrating.

Advertisement

Robin_j
Joined:
Posts:
2

New proxy prompt can be really frustrating.

Some time ago this (https://winscp.net/tracker/468) was implemented probably because of this https://winscp.net/forum/viewtopic.php?t=30355 request.
While I understand the need in this scenario, the inability to turn this behavior off makes WinSCP almost unusable for me.
I am using a socks proxy that is only reachable inside a VPN to prevent accidental connections while I am not connected to it. This proxy does not require any authentication credentials and in combination with many background connections this leads to a constant spam of authentication prompts I always have to confirm without entering anything. Each new background connection WinSCP establishes triggers another prompt.
I am constantly juggling 3–6 different servers all of which use this socks proxy setting and I frequently upload or download lots of small files which is a lot faster by using multiple background connections.
Maybe I am just blind but I couldn't find a way of turning this new behavior off.

Please provide a way somewhere to give the user the option to choose.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
38,438
Location:
Prague, Czechia

Re: New proxy prompt can be really frustrating.

The feature was implemented in PuTTY 0.77. That's how it got into WinSCP.
Can you confirm that you have the same problem with PuTTY? To verify that we didn't do anything wrong when propagating the changes to WinSCP. Also, wouldn't it help to enter dummy proxy credentials in the settings?

Reply with quote

Robin_j
Joined:
Posts:
2

re re

Just trying dummy credentials was the first thing I tried and sadly it seems like only empty credentials are accepted by this SOCKS5 proxy.
I have no way of changing the VPN's behavior of not accepting dummy login data.
I just checked and you are indeed correct. PuTTY exhibits exactly the same behavior.
I should have been using this same setting in PuTTY too but it never even occurred to me.

This is much more frustrating in WinSCP because PuTTY never establishes a connection without explicit user input by default and it only requires 2 clicks to reestablish a dropped connection so it's not a significant annoyance.
WinSCP on the other hand needs to automatically reestablish connections if it's supposed to be able to work off a big workload in the background.
But this might lead to WinSCP re-establishing a connection after the VPN connection dropped which is a real danger.

I can see how you might be reluctant to deviate from the new standard behavior of the base application you are wrapping your GUI around but imo the use-case of WinSCP is so different from PuTTY that such an option would still be absolutely justified.
Last edited by Robin_j on 2022-08-02 10:52; edited 1 time in total

PUTTY_2022-08-02_00-26-50.png

Reply with quote

oldversionFTW
Guest

reverted.

Hey there I upgraded my WinSCP from 2020(!) to latest(2022) and I got sick of this "proxy username/password" input each time I try to login to remote. Before this upgrade I was able to login by just 1-click. Now I have to click enter by Mouse each time.

https://winscp.net/eng/docs/ui_authenticate#proxy
it will prompt for the missing credentials.
Just. Stop.

The user WOULD add username/password in configuration UI if the proxy REALLY needs them. If the value is empty it is empty. DO NOT ask for it.

Reverted to 2020.

Reply with quote

Advertisement

stitch3210
Joined:
Posts:
1

I don't get, why this bug even has to be upvoted, in order to be dealt with – I find it obvious, that it's really an annoying, unnecessary issue.

I like the fact, that WinSCP monitors changes to remote files that are currently being edited.
I use this a lot.
What happens now, is that I modify a file and expect WinSCP to upload the change in the background, as it has always done. But sometimes it doesn't. Because the connection has been reestablished (dropped in the meantime for whatever reasons) and there's that superfluous credentials prompt somewhere hidden behind a number of other windows - preventing the automatic re-connect that in past versions happened seamlessly.
And I'm sitting there, scratching my head, wondering why my changes didn't take effect. Until I remember, that the new WinSCP is messing things up again.

Pleeeeeease get rid of this prompt box. Have credentials be optional. A Checkbox.
A lot of proxies (my guess is: in reality most) are used without credentials.

EDIT: actually, it's worse, it prompts even if the connection wasn't dropped in the meantime. I suppose, it does it, whenever it uploads the file for the first time.

Reply with quote

martin
Site Admin
martin avatar

stitch3210 wrote:

I don't get, why this bug even has to be upvoted, in order to be dealt with – I find it obvious, that it's really an annoying, unnecessary issue.
It's about limited resources and priorities. I cannot fix everything that annoys someone. That's what bug tracker is about.

Reply with quote

Advertisement

You can post new topics in this forum