Problem with file of Text from HP-Nonstop, truncates the file to the EOF size of the source File.

Advertisement

JSaaGerbier
Joined:
Posts:
2
Location:
Chile

Problem with file of Text from HP-Nonstop, truncates the file to the EOF size of the source File.

When I used WinSCP to download a GUARDIAN ASCII file from a HP-nonstop via 'sftp' in the OSS personality, it normally works fine, but it always truncates the file to the EOF size of the source file.

Guardian-Ascii files (EDIT files) on the HP-nonstop are have an internal format, so when the file is download from the HP-nonstop it is converted to ascii by the SFTP server on the HP-nonstop and sends it in ascii format to my pc.

Once the file has been transmitted to my PC, the File is closed. The EOF of the file is = to the number of characters in the file on my PC.

I have noticed that when the EOF of the file on the HP-nonstop is less than the number of characters it takes to store the file on my PC, WinSCP sets the EOF of the file on my PC to be equal to that on the HP-nonstop, thus truncating text files.

Is Winscp checking the EOF before it downloads a file and then only downloads for the EOF size or is WinSCP downloading the file and then setting the EOF to the EOF from the source file?

However the ascii on the NonStop (Guardian EDIT file) is not pure text and can contain compressed lines, so the file's EOF is less that if the file was converted to a NL separated file (UNIX like). We believe that the tools that work correctly, just read until EOF is posted. The SFTP server on the NonStop converts the edit file to a UNIX text file on the fly) Since nothing on a windows box can read the contents of an EDIT file, a transfer in binary mode is not an option.

Is there a configuration I am not setting correctly that could resolve this problem?
  • WinSCP.log (42.03 KB, Private file)
Description: Log of Test

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
38,408
Location:
Prague, Czechia

Re: Problem with file of Text from HP-Nonstop, truncates the file to the EOF size of the source File.

WinSCP does not set any EOF. The file should be downloaded as it is. Though, did you try using binary mode, just in case the WinSCP ascii conversion somehow messes up your file?

Reply with quote

JSaaGerbier
Joined:
Posts:
2
Location:
Chile

Re: Problem with file of Text from HP-Nonstop, truncates the file to the EOF size of the source File.

Good morning Martin, my apologies, among so many tests, I attached the wrong file.
I did an isolated test and I am attaching the new Log file. In addition, the image shows the difference between doing the transfer natively (with comForte) and with WinSCP.

Thank you very much.

Description: Image with size of the file

Captura_B24.PNG

Description: Log of new Test

Reply with quote

martin
Site Admin
martin avatar

Re: Problem with file of Text from HP-Nonstop, truncates the file to the EOF size of the source File.

The log of bcsecd transfer still shows ascii mode.

Anyway, try to add -rawsettings SFTPMaxPacketSize=32768 to the open command. Set logging level to 1 (/loglevel=1 on commandline) and post new log.

Reply with quote

Guest

Problem with file of Text from HP-Nonstop, truncates the file to the EOF size of the source File.

Good morning Martin, thank you very much, problem solved!

I followed your prompt to add -rawsettings SFTPMaxPacketSize=32768 and it worked.

Just say that finally the open was:
-rawsettings SFTPMaxPacketSize=32768 RekeyBytes=0 FSProtocol=2 Utf=0 loglevel=1
And the files are all ascii (sorry if I wasn't clear).
Description: Log of the new test

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
38,408
Location:
Prague, Czechia

Re: Problem with file of Text from HP-Nonstop, truncates the file to the EOF size of the source File.

Ok. Note that this is just a workaround for a bug. Whether it's WinSCP or server bug I cannot tell at this moment. If you want us to investigate further, please post Debug 2 level log file for the original setup (without the SFTPMaxPacketSize).

Btw, the loglevel=1 in your example is wrong. It has no effect there.

Reply with quote

Advertisement

You can post new topics in this forum