Windows 11 WinSCP GUI will lock up / not redraw (after a day or so) – must be force killed

Advertisement

ron423d
Joined:
Posts:
9
Location:
UK

Windows 11 WinSCP GUI will lock up / not redraw (after a day or so) – must be force killed

Info first:
  • Windows 11 21H2 build: 22000.918
  • WinSCP v 5.21.3 (12800 2022-09-06) – (Also occurred with updated from ~ 4 months prior to this)
  • exclusively use SCP (protocol)
  • I do have a WinSCP master password in place (I have ~ 30x Session bookmarks saved, if that's relevant)
  • NO Antivirus in place, Win Defender is disabled. Occasionally I run Manual AV scans, such as via Microsoft's MSERT tool, (also via bootable USB AV scan tools) -> clean results.
  • AMD EPYC CPU (7262), on a Supermicro X11 Motherboard, with 128gb ECC ram (is server hardware i use for my daily desktop)
  • NO WinSCP scripting NOR automation in use (never have used those)
  • 2x Nvidia RTX4000 GPUs, Nvidia "Studio" drivers version: 516.94 (also occurred with prior Nvidia "Studio" drivers from ~ 4 months ago, which were ~ version 480.x)
  • I'm one who does not update software except when: there is an issue, a security reason/patch, or a new feature I need (so not very frequently, on average every 6 months or so).
  • NO WinSCP log file attached (would it help if I enabled session logging, and waited for this GUI issue/lockup to occur? I'm assuming no, it will not log anything, but if so I will do that)
ISSUE: I usually always have WinSCP open in the background, with anywhere from 1 to 10x WinSCP tabs connected. Usually after 12h to 36h WinSCP will lock up (as seen in image below). When it does this, the only way to exit is to Task Manager->Kill winscp.exe. This started about 8 months ago when I did a WinSCP update, after not doing one since ~mid 2021. Prior to the 8month ago WinSCP update, I had never seen this occur with WinSCP at all. (prior WinSCP was very stable, although at times sluggish in the GUI, but overall worked great!). So as of a week ago, I decided to update to latest: my Windows 11, WinSCP, and Nvidia drivers (still at the Nvidia "studio" driver level/type). The issue still occurs.

I'm sorry I cant say the exact WinSCP version # that this started occurring at, however I can say that this does NOT seem to be related to Win11, as when I first built this PC about 1.5yrs ago, I started with a clean/fresh Windows 11 install, and the latest WinSCP, and did NOT see this crash/lockup issue for several months (it seems to have started when I updated WinSCP ~8-12months ago from now)

When this does occur to WinSCP, no other apps seem to be effected. Any suggestions or additional info I can provide?
Thanks!
(LOVE WINSCP !!!)

winscp crash img.JPG

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
38,408
Location:
Prague, Czechia

Re: W11 - WinSCP gui will lock up / not redraw (after a day or so) - must be force killed

Thanks for your report.
I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

Taomyn
Joined:
Posts:
11
Location:
Luxembourg

Same just started happening to me

I came looking for the exact same problem which started happening to me today. I've been connected all week to my Windows Server 2022 via RDP, and connected to one or two SSH sessions when today connected to just one machine I keep finding the application hung up.

I have tried the same connection on another machine, a Windows 11 workstation, but it's been fine.

Reply with quote

Advertisement

ron423d
Joined:
Posts:
9
Location:
UK

Is it ok to run the debug version twice?

I mean to have 2x of the portable WinSCP's debug versions running.

(I ask as I usually run 2x versions of my standard WinSCP v5.2x, I started doing this due to the long tab names of multiple SCP sessions, which seems to be addressed in the future v6.0).

I wanted to ask before I run the debug version twice and possibly mess up its trace/capture. tks

Reply with quote

ron423d
Joined:
Posts:
9
Location:
UK

Thanks Martin, I was actually able to capture v6.0 debug version when the issue occurred!

So I will be emailing you the trace log, and here is a screen cap of when it happened:

Description: v6.0 debug locked up

image.png-mh (2).png

Reply with quote

Advertisement

You can post new topics in this forum