WinSCP Doesn't update remote folder (Commander) after file or folder delete

Advertisement

guest6481
Joined:
Posts:
12

WinSCP Doesn't update remote folder (Commander) after file or folder delete

Same setup as: WinSCP DELETES files instead of giving "file not found" warnings (since 4.1.3 and possibly before)
When using Commander, with "auto-refresh remote window" on,
the remote window only updates when you manually delete a file or folder.
If you F6 (copy/delete), after the file is moved successfully, the remote window DOES NOT REFRESH. This contributed to the previous bug I reported: re-moving files that no longer exist.

[sorry so short ; am DISABLED ; hard to type everything out]

Should it refresh after EVERY file transfer, or when the queue is done? I say: after each transfer completes (but that may anger people with 5,000 files in their dir). Perhaps a new option: "refresh remote dir after file transfer" combo-box: [never], [after copy/move: each file], [only after transfer queue is completed]

Versions 4.1.3 --> 6.0.0-20221111

2.png

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
38,408
Location:
Prague, Czechia

Re: WinSCP Doesn't update remote folder (Commander) after file or folder delete

I'm sorry, but I cannot reproduce this. Not even with FTP and background transfers. Please post session log file. Screenshots before (including transfer options dialog) and after might also help. Thanks.

Reply with quote

guest6481
Joined:
Posts:
12

Re: WinSCP Doesn't update remote folder (Commander) after file or folder delete

I'm transferring over 14 TiB; I don't think you want a 5MB log?

I thought my description was simple enough.

You have a directory. [11.png]

You F6 [Move] the directory from the remote dir (*nix) to local (Windows). [12.png: "Live CD"]

When the directory is completely transferred, the remote directory DOES NOT REFRESH! [13.png: "Live CD" is still listed but the directory has already been deleted]

You have to manually press Ctrl+R to manually refresh the directory. [14.png: after pressing Ctrl+R]

I've had to do this for YEARS with your program (versions 4.1.3 – 6.0.0-20221111)! Just like you couldn't find the last bug ... then you did. I'm not lying and I'm not stupid.

Reporting years-old bugs shouldn't be so hard.
  • pix.zip (324.3 KB, Private file)
Description: 4 images per description above

Reply with quote

martin
Site Admin
martin avatar
Joined:
Posts:
38,408
Location:
Prague, Czechia

Re: WinSCP Doesn't update remote folder (Commander) after file or folder delete

I definitely want your 5MB log file. Though, are you sure you need to transfer 15 TiB to reproduce and document the problem?

I'm sorry you have the problem for years, but I do not remember anyone reporting such problem before. As I already wrote, I cannot reproduce it, not even with FTP and background transfers. So it must be something even more specific.

Reply with quote

Advertisement

You can post new topics in this forum