Exception when opening session

Advertisement

Enforcer1976
Joined:
Posts:
6

Exception when opening session

Hello! A problem when opening a session, and on some computers. When viewed in the debugger, I found that the error appears if HomePath throws an exception. If HomePath = "\" then everything is fine. Tell me what can be done? Attached is the debug log and a screenshot of the error.

Exeption.jpg

  • 1.log (13.95 KB, Private file)

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
40,736
Location:
Prague, Czechia

Re: Exception when opening session

On the computers where the code fails, what happens if you run:
winscp.com /ini=nul /command "echo test" "exit"

Reply with quote

martin
Site Admin
martin avatar

I have sent you an email with a debug version of WinSCP to the address you have used to register on this forum.

Reply with quote

Advertisement

Enforcer1976
Joined:
Posts:
6

Hello! Used a new assembly of the library, running through the command line as indicated above. At the first start there were no errors, the word test appeared. But the second and subsequent runs result in the same zero error. I am attaching the log file.
  • WinSCP5144trace.log (95.68 KB, Private file)

Reply with quote

Advertisement

Advertisement

martin
Site Admin
martin avatar

Ok, I didn't understand your previous post.
Can you please re-test the development version I've sent you? Because that and the last debug build should be the same. Note that in your post about results of the "Development" version test, you have attached a debug log. But the development version does not produce any. Maybe I've misunderstood that post too.

Reply with quote

Advertisement

You can post new topics in this forum