Unable to workaround time differences

Advertisement

apour
Joined:
Posts:
1

Unable to workaround time differences

Hello,

I'm synchronizing Windows (2008 R2) folders with remote Linux running vsftpd (old 2.0.x version). The Linux machine is unfortunately beyond my control as far as configuration and/or upgrade is considered. Both machines are in the same timezone but Linux timezone configuration is most likely incorrect, Windows is correct (GMT+1 with DST), and when daylight changes, synchronization is messed by the timestamps and older files are re-uploaded.

It seems that time difference check is using oldest file. In a job syncing a folder with files created before summer time, WinSCP detects -1 hour diff, a job with newer files folder it is -2.
Is there a way to tell winscp to use the most recent file to detect time diff? I tried to change listing command to reverse order by time:
open ftp://XXX/ -rawsettings FtpUseMlsd=off ListingCommand='ls -alt'
I also tried to set TimeDifference=0, but did not help.

Thank you in advance.

Reply with quote

Advertisement

martin
Site Admin
martin avatar
Joined:
Posts:
41,032
Location:
Prague, Czechia

Re: Unable to workaround time differences

The TimeDifference settings has rather specific format:
https://winscp.net/eng/docs/rawsettings#timedifference
The easy way to get the right value is to configure it in the GUI. And have it generate the code template for you:
https://winscp.net/eng/docs/ui_generateurl#script

The ListingCommand has no effect on FTP (it's for SCP only).

What you can also do is to make WinSCP start in a folder, where there's only one specific file that you want to be used for time zone autodetection.

Reply with quote

Advertisement

You can post new topics in this forum